[Main thread] Login screen infinite loop

Still stuck in a login loop

1 Like

Same here still stuck in login loop since the game came out

Same here, was able to log in once when the game first came out and ever since then have been stuck in the loop. Hopefully they fix this soon.

Having the same problem.

Still having the same problem since launch. I couldn’t even get to the main menu,

Same here, I played once for a short time on launch day (though it took several hours to get in) and since then I’ve been getting the login loop. I was hoping the two rounds of server maintenance earlier were going to fix it but sadly not.

The only comfort at this point is their launch status update yesterday:

Figured I’d at least share that for anyone that missed it, could be of help.

I’m really hoping the “being unable to log in at all” point is about this log-in loop issue, but regardless I’m getting tired of waiting (especially with fixing the database slowly), easily the worst launch I’ve ever personally experienced. Tempted to make an alt account just so I can play with friends in the meantime.

Yeah my game won’t even let me play. I load up the game as normal but when I press play on the title screen it says “connecting” then it disappears. I’ve sat on this screen for 20 minutes hoping it would log me in but to no avail


Same issue over here. Infuriating. Just a constant, nonstop loop of:

Searching for a Game Session…
Connecting to Game Session…
Entering Game…

Email or Phone


That might be it maybe my two accounts are set to use the same player database nodes and my wife’s is on another.

1 Like

Since I have nothing else to do really except have a few drinks and speculate. “The process of adding nodes requires replication of data” Is interesting. It sounds like they have the player base divided up into little chunks. Sounds like these nodes aren’t something you just randomly route through when trying to connect but your account data is stored and categorized by them.

1 Like

I’m glad it’s not just me, this only seemed to have happened once I set my SMS attatch and then restarted. I get to the end of the queue and then get no prompt to proceed.

1 Like

Yes, it’s almost 100% nothing you have done and nothing you can do to troubleshoot or fix. There are just large amounts of accounts that can’t connect to the game period. I actually was typing this is probably the worst launch blizz has had but tbc classic entire realms data and characters were lost and they had to roll back to a previous snapshot iirc. So I’d say probably not the worst but we’ll have to see after more info on what’s happening comes out.

1 Like

did they say when this would be fixed been trying since the game came out had the issue legit from the first minute i just wanna play

it’s legit driving me insane, 72h in that i can’t play lol, battle pass bought etc etc


Yup same as me.

Everytime I press play in Overwatch 2 it starts with connecting to game server, entering game, then asks me for my Email or Phone and password.

I tried reinstalling, scanning and repairing, flushing my DNS, changing wifi’s but nothing helped. This issue started happening after I changed my merge account from my PS4 account to my Xbox account. I got the notification that if I log out and log back in since the merge was successfully I’ll be good to go but I haven’t been able to get INTO the game since yesterday morning since it keeps asking for me to log in with my Email/Password.

Tried changing my password and still nothing.


Yeah, it’s so frustrating. As far as I’m aware I didn’t even merge my account with a console account and I’m still getting it. The most I can think that I did was add my google login to my account? But I’m pretty sure I did that significantly before I started getting this issue so who knows.

I think we should delete this piece of …
support just literally doing nothing to help us out

agreed. all we can really do now is pray that this problem is big enough that it gets fixed quickly cause there is obviously nothing we can do on our end to fix it…

same here!! it’s been like that for me since the maintenance ended

1 Like

Also having this problem. I was able to get on a few games yesterday but started having issues when I tried playing today.

1 Like