Lost connection to game server

I have had overwatch for over 1 year and havent had anything like this happen before. When i launch the game once it gets to the normal menu it stays there for about 30 sec then logs me out and say “Lost connection to game server”. Please help

2 Likes

The same thing happens to me. Everything was fine yesterday. Closed and reopened the game a few times and all was good.

Then today I get on and it freezes on the menu after a few seconds or if I click on anything, boots me to the login screen, and does not allow me to login

Unfortunately all disconnections and game crashes counts as leaving the match and will be penalized appropriately. The game server has no way to discern a legitimate disconnection or game crash from one that is forcefully caused by a dishonest player to bypass leaver penalties. You can learn about this policy here:

Remember if you see the message, “Lost Connection to the Server” in the title screen or the message “Failed to Connect to Server” in yellow text in the text chat box, this means there is something that disrupted your connection to the game server and not a problem with the game server itself. There can be a variety of reasons this happens including those that don’t disconnect your computer from the Internet. There is great troubleshooting to start with that can most likely resolve most issues and I encourage you to check them out here:

https://us.battle.net/support/article/000112208

As always if nothing in that guide works, please reply saying you completed these steps and additional advice can be provided. Good luck!

(^^)v

Same issue. Have this problem since several weeks.

Its gonna be nice when Blizzard finally gives up on the whole its not on our end response. It isn’t like its 1-2 people with this issue. Just take a look at the forums. Multiple posts, a lot of people.

2 Likes

True, there are multiple posts from multiple people, but that doesn’t mean that they all have the same problem. The internet is an extremely large and complex beast where a number of different things can go wrong. You can find a lot more information on this here - including some troubleshooting and an FAQ post which will give you more reasoning on why we treat these issues individually.

You folks don’t share an ISP or any other common factors which would make me think your problems are linked. Since you’re not the original poster I’ll need to ask you to create your own thread. If you can provide the information I ask for in the thread I just linked, we can look into your specific issue and help you try to find the resolution.

This disconnection only happens in the first few minutes of booting up the game. The last 2 days I entered a comp match and got disconnected before it began. My internet did not go out and this only happens in Overwatch, not other games. Because of disconnect, we lose that much SR and a 30 minute suspension?? Sounds like a common problem with Overwatch and the Blizzard servers if this is happening that much. But from reading here in the forum, the blame is put solely on the players and their internet connection. What has Blizzard done to find a solution to this problem?