It's 2019 and we still have this issue

and somehow ‘device rendering lost’ still exists! Lost 50 SR and 10 min suspension. thanks (oh and best part was about to win 7th game in a row yet I’m still punished)! <3


The “rendering device lost” error occurs for a variety of reasons. but the general symptom is that the graphics card running OverWatch shut down while the program was still running.

For most users, this is often due to outdated graphic card drivers, overheating components, or other conflicting software issues. Troubleshooting is available here:

For users with Nvidia RTX 20X0 series graphic cards, There is a known issue with the graphic card driver conflicting with the file executable for Overwatch. However there is a possible temporary work-around as they work to solve this problem with Nvidia. Learn more about that in this post:

I’m wondering how is this possible with ONLY Overwatch? I play a lot of other games, both pvp and single and OW is literally the only one this issue pops up frequently. I’m a GTX 1080 owner and tried literally everything. Problem still exists after years.

1 Like

The “rendering device lost” message is Overwatch’s unique error message to a symptom that can occur to any game. Other games may say “graphic card failed” or simply give a generic error code.

Of course I know it lol. I meant there is no crashes or errors in other games at all. They’re all fine.

1 Like

In your case, I recommend checking for software conflicts.

If you need specific advice, please start a new topic in the technical support forum and share a DxDiag file.

While I didn’t have crashes during my session today, there were massive input lags or idk what exactly it was that caused my screen to freeze multiple times in a minute aswell as overload my CPU. I have all settings on low and other games with high graphics don’t lag at all. Gonna upgrade my PC anyway so why I did I even type this lmfao

For you I would recommend checking out this troubleshooting:

and i’m willing to bet in your nvidia control panel

you don’t have maximum number of pre-rendered frames set to 1

having it set to 2 wich is nvidia default causes this game a ton of issues

and yes could also be heat releated issues aswell with your gpu overheating

Thank you sir/ma’am.

Yeah, but I’ve actually only had this happen with Overwatch. Never Elite Dangerous, Monster Hunter, Shadow of War, TF2 or anything else. Hell, I’ve had Oldrim crash with errors even close to being like that less than I’ve overwatch and I use those screenshot ENBs in normal gameplay. The only time I’ve had something like that happen is when mistakenly I bumped the sub-surf on a model with 85k faces up to 4x before rendering in blender.

Got this value set to 1, issue happens. Tried without overriding just because why not, also happens.
About overheating, monitored my hardware during the crash already, temp wasn’t even close to critical value.

1 Like