I can't launch the game

Logging out and then back into a new region worked for me.

Yeah, but the feed is still messed up.

Okay! Now that I’ve got most of you in one thread, here’s what’s going on.

There’s an ad currently for the Nintendo switch port of Overwatch that’s covering up your app. For some reason it’s invisible for you. It looks like most of you are in Australia, and most of you in Australia are on Telstra internet. We think there’s something causing the Americas version of the ad to be blocked by your ISP, which is why swapping regions works.

If you haven’t already fixed your issue, it’d help us to get log goblin files. You can run this tool and then email the results here:

Email: techinfo@blizzard.com
Subject: Attn: Drakuloth - Overwatch Switch Ad Invisible

Please note that this inbox is not monitored and does not receive replies for technical issues. We use it to collect files for troubleshooting.

You should be able to fix this in one of two ways. One, you can log out of the app, then log back into another region (such as Europe), which should allow you to close the ad and fix the problem. The other option is to hover over the top right corner of the blank space on your app. There should be an invisible “X” button there you can click. If that option does not work let us know.


Done, also out of interest are you other guys with this issue missing your normal Newsfeed boxes on the page for each of your games?

Yep, none of my news feeds work for any game on BNet while set to Americas, Europe works fine for all of them however.

1 Like

After the region fix my feed looks like this on all games. I even uninstalled, deleted all cache folders and related registry keys and reinstalled to try to fix the feed. If I log into another region the feed looks normal.

h ttps://imgur.com/Sz4e1M5

2 posts were split to a new topic: Nerdygamer1 - Game Doesn’t Launch

Ooh that’s weird; mine just has nothing there, not a text box.

6 posts were split to a new topic: Robokun - Black Screen Crash

Technical support also sent me to this thread as I am having the exact same issues. However, my main concern now is how do I purchase Modern Warfare and have an option to install it when facing a blank screen? I can click the store button to purchase it that way however worried when I go to install I am not going to have an option to pre-install or play.

The changing regions worked for Overwatch and other games that I already own so I can at least now install/play them (still can’t see the main screen)

Would changing regions give me that option then switch the region back? I am happy to use that as a workaround if I can get confirmation before forking out money for a game I may not be able to play.

Apart from having this issue some time ago, after fixing it , months later , i found anothe issue to launching the game. After launching it, it told me that i havent got a overwatch license. I have the physical CD with the game, i bought from Altex.[a game shop that has never dissapointed me and ha s never had ‘pirated games’ as i ve never had the issue before neither have my friends that bought this game from there too]. After putting in the cd it still gave me the same message. Help??? :persevere:

yeah i have the same problem and if you try to scan after corrupted files it still doesn’t work so i have no idea what to do know . ill just wait it out i guess.

Figures Telstra would have something to do with it.
Still no Newsfeed. :frowning:

Fully exited Blizzard Launcher and re-opened today
(as I had many times before)
and noticed that my newsfeed boxes have come back!
If you guys fixed something, or Telstra fixed something or both
it worked and they’re back, for me at least.
Much thanks!

This should also prevent the problem of no play button on Overwatch if it’s fixed for all affected.

Great to hear Drizella! Anybody else seeing positive results with the news feed?