I can't launch the game

I switched my battlenet too the beta version in the settings and now overwatch works fine.

I get a blank all white screen for the whole app.
I get this error: The procedure entry point ucrtbase._cexit could not be located in the dynamic link library api-ms-win-crt-private-|1-1-0.dll.

Never had a problem since game launch. I am assuming its from overwatch Halloween update, as I see it started to do an update. Was working fine yesterday. I uninstalled the battlenet app, then the game once that didn’t work, restarted and still has the same issue…

I just laughed when I saw that, because I knew I wouldn’t be the only one, and overwatch just really wants me to move on from the game I guess. All other games work fine on steam and epic launchers.

Edit: New info from the staff suggests this issue is affecting a specific group of players.

tried this and nothing has changed

1 Like

i am also getting this problem and the fix proposed did nothing

also getting the same issue.
the proposed fix did not work either.

no 3rd party antivirus and my installed location is excluded from defender.

I got the same issue. game won’t even load by itself even when run as admin…

the problem may lie with a pop up that comes up advertising overwatch on switch.
the pop up does not show and as such the play button is removed. in order to get this pop up to come back up is to log out then log back in into a different region.
EX. i live in the americas so i log out then when logging in there is a box to switch region, i switched to europe then logged in. when i logged in, the pop up appeared and i was able to click the X to close the pop up. i then switched back to american servers and the play button was visible to click on.
i hope this helps you! and if you see any other similar questions or problems i advise to spread the word as i have done


this worked!! thanks bro

These kind of issues belong to #technical-support, i’d recommend you take this issue to #technical-support they might be able to fix it for you.

Do so by editing this topic and changing the post destination to #technical-support.

I’m having the same issue. Unable to launch Overwatch since the Halloween patch.

Trying the Europe trick did nothing. I haven’t had the newsfeed for probably a year on my launcher, but always had the play button. I also had no notification of the update aside from the far left collapsible menu.

it is a problem with a pop up
log out of the blizzard launcher then log back in under a different region
it should reinitialize the pop up’s code and then just exit out of the pop up by clicking the X to re-enable the play button

Doesn’t work. Still blank. Need to launch overwatch.exe manually to play the game now.

it was worth a try, i guess you have a different problem than i did.

It makes me wonder why I ever used the launcher anyway. I might as well uninstall. It seems better just to launch overwatch myself if it’s the only blizzard game I play.

Hey, I’m having this issue too. But its not just Overwatch on the Blizz Launcher, my starcraft and warcraft 3 games also don’t have launch options :frowning:

I’ve tried restarting the client, letting it update, restarting my computer, letting it sit open for a while. nothing

yeah me too :confused: hopefully they patch it soon

This was happening for me too, all you have to do is:

  • Log out
  • Login to a different region (if you were in Europe, go to Americas, etc)
  • Log out again
  • Log back in to your normal region.

Have you found a fix? This has happened to me too

This worked for me my man

1 Like