I can't launch the game

Cheers! It worked! :slight_smile:

I’ve been having issues launching the game after the update also. Screen goes black then quickly goes back to desktop with a bug report window. The system tray work around doesn’t seem to be working for me sadly.

Same issue here.
Deleting the cache as mentioned here: https://us.battle.net/support/en/article/34721 - gives me the blue looping loading ribbon for a moment before putting me back on a blank Overwatch screen.
It still auto-updated and I can launch and login directly from Overwatch.exe, but launcher is borked.

Yeah, when i go on battle.net and click overwatch, its black with the overwatch background and 2 white squares in the top left corner, and right clicking the battle.net app and selecting overwatch didnt work for me sadly >:(

Still having this issue, It’s been around 14 hours now and I still have not been able to log onto the game. This is getting frustrating now…

Edit: New info from the staff suggests this issue is affecting a specific group of players.


If you are launching and getting a black screen, your issue is not the same as the OP. Instead, this issue is covered in the sticky threads here: Known Technical Support Issues - [Updated Sept 9, 2019!]

Pay special attention to manually remove the files listed in that post.

Hope this helps. :crossed_fingers:

Turns out pausing Avast causes the game to load up perfectly fine, but i’ll try this also now I’ve seen it for a hopefully permanent fix that doesn’t require pausing Avast. Cheers

1 Like

Thanks for reporting back!

I was getting the same/similar black screen after launching from the Bnet, sadly right clicking in the sys tray and choosing OW didn’t work for me either. I installed OW on my laptop and it played fine. Went back to this system tried disabling my AV, doing a scan and repair and verifying I had the latest patch. I ended up uninstalling, restarting and then reinstalled the game and it works fine now. So something when it updated didn’t take.

Yeah. That works for me as well.

Thanks muchly for the suggestion.

It didn’t work for me. I deleted the CachedData.db file like you said and when I load the blizzard app again it does the exact same thing, The overwatch page is completely blank and I can’t do anything. I even tried what Avenger99 said, to uninstall the game, restart my computer and reinstall the game. But now I can’t reinstall the game cause it is still blank…

Are you using any type of antivirus and can you disable it? The blank page is likely the advertisement for the switch version.

I am using Malwarebytes and I just disabled it. I opened the app and its still blank

Edit: New info from the staff suggests this issue is affecting a specific group of players.

I got it to work, I had to uninstall overwatch AND the blizzard app completely and reinstall… Overwatch installed and it wasn’t blank anymore. It was just saying that it couldn’t load whatever it was trying to load. So I finally got onto the game… Unfortunately when I left the game and checked the blizzard app it was blank again… now I have to uninstall everything again and reinstall it all again just to play.

What do you mean by opening a ticket?

Day 2 and still blank despite things suggested to fix it. It should also be known WoW, Diablo, Starcraft II and all the others have their pages look fine (buttons showing etc), but Overwatch and Starcraft too are entirely blank, and it’s the same for a bunch of friends which also have tried similar steps.

So far the only way to access Overwatch is through the system tray right clicking the OW symbol there.

Just seems strange that it’s the same for the Starcraft tab also.

Thanks for the fix man, I can finally play the game haha

Same issue, the reason it’s blank seems to be that it’s trying to open up a window about the halloween event that takes up the screen but for a couple of days I haven’t had news feed boxes popping up for any of my games.

I FOUND that if I log out of Blizzard app and change my region to Europe when it loads up I get the pop-up message, close it, then when I switch back to US I can see the play button.

Still no NewsFeed boxes but I can at least play Overwatch.

As an aside if Blizzard is working on a fix for this I have uninstalled, cleared %appdata%, %localappdata% and %programdata% of all Battlenet or Blizzard files. Anything left in program files, reinstalled twice, disabled all anti virus software and firewalls and it’s still an issue in my Blizzard launcher. Newsfeed boxes do not show up in Americas region, only when I switch to Europe.

For me I fail to connect to server 100% of times
Pls help