Huge fps drop and stutter

So I just got ow on my laptop yesterday and it was capable of running at 100-130 fps in game, however today it cant even handle 30 fps. I have not done anything except lower the graphics quality. Every once in a blue moon, it will be able to run 60 fps, however on normal occasions it will always stutter from 60 to 30 fps and if I set it to 30 fps, it will stutter to 25 fps so whenever I play, I get a screen freeze every 2 seconds or so.

Are you using any Razer peripherals?

Have you checked for overheating components?

The only razor device in my house is a razer sila. Temperature is about 60-75 degrees. Another reason I’m pretty sure overheating is not the problem is because I turned my laptop off right before going to bed and the only thing I did before playing ow was watching a short youtube video.

All right, let’s check out a diagnostic report.

Click here to show/hide DxDiag instructions
  1. Press Windows Key + R, then type DxDiag and press Enter.
  2. In the DxDiag window, click Save All Information.
  3. Name the file “dxdiag” and click Save.

To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

If your DxDiag does not fit in one message do not shorten it. Instead, post it on Pastebin.com and provide the hash code (the numbers/letters after the .com) in your reply, not the entire link because you can’t post those.

While you wait for assistance, I suggest opening the Windows Reliability History tool, which will likely show you what’s happening in the background to cause any errors.

Qd9gFnMt
Thanks for putting in the time to help :slight_smile:

Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: RtkAudUService64.exe

Looks like your audio drivers are crashing, so you may need to reinstall them from your motherboard’s manufacturer website. I also recommend during off the Xbox Game Bar in the Control Panel.

Let me know how it goes.

Overwatch runs at 120 fps now :D. Thanks nicole!

I’m having the same problem and there’s no issues on my windows reliability history. Tried all suggested solutions as well on your FPS drops page, nothing is working. Can’t submit a help ticket either for some reason. System info: https:// pastebin . com/yn3g3dm6 ////// https :// pastebin. com/52KAfFLG

1 Like

and fps is horrendous again

1 Like

Since none of your errors were related to Overwatch in your diagnostic report, it’s still going to be a local issue. Have you checked for overheating also? https://us.battle.net/support/en/article/31363

If you upload some pictures with all hardware expanded to Imgur, I can take a look (provide the link same way as dxdiag).

Your other option is to open a ticket and wait to consult with the staff.

Your issue is something different. Please start a new thread instead of piggybacking here.

overheating isnt the problem. Highest temp is 73 degrees.

Okay, since there wasn’t anything related to Overwatch in your report, this is definitely a different local configuration issue. Without screenshots confirming usage and temps of hardware, I don’t have any further insight to offer here. I recommend using the ticket system to communicate with the staff for further assistance.