Glitching in and out of Retribution


Im currently wireless


I am currently wired


I managed to fix my issues by enabling QoS on my router I’m using a netgear R6220 router.

I’m wired.


im currently wireless


I was wireless when I was doing it, and I only tried the story mode for retribution, none of the other event modes due to the current issue.


Just an update, was able to update my firmware for my router and that with the reddit post fix seems to have worked, just ran through a game of retribution with no issues.


I don’t know if it is me maybe but for no reason during the retribution and the uprising events, when I am in the middle of the game, I will be randomly kicked and it will say client server disconnect, maybe it is a problem with my router but if there is any way to fix it I would love to because I hate having to abandon my teammates especially if we are close to winning.


I also have a Netgear AC1200 and it happens in all modes of Uprising and Retribution. I am hardwired


I have a Netgear R6230 router and the same issue where I get booted to the menu in the event every minute or two. I have a wired connection and the Reddit suggestion of turning QoS on with warcraft set at highest priority worked to fix it for me.


I updated the firmware and changed the QoS settings on my Netgear AC1200 router and still having the EXACT same issues.


Followed the instructions in the reddit post and updated my routers firmware, still affected by the issue. I have a Netgear R6220 and am wired (wireless is not an option for me).


Are there any updates for this issue ?

(Cathy Lee ) #35

Good morning!
The investigation is ongoing but I have some more information for those of you that are still encountering this issue.

Can you try prioritizing UDP ports 26503-36503 and let me know if that makes a difference.

Thanks so much!

Losing connection on Retribution/Uprising Expert or Legendary
Really high latency after retribution patch

no difference for me


Didn’t make a difference


im always using a wired connection.


I had already optimized those ports and there was no change


Okay so apparently I forgot to tick the Turn On QoS box and now I feel like an idiot. It’s working as intended now, thanks for the help!


Also I am not able to get achievements like completing Retribution and Uprising with all 4 characters or 8 different characters in all players mode. I just played through with all 4 characters in a row to test and still no achievement. There is only 3 days left of this and they have made no progress to fix this issue. Thanks a F******g lot


Can anyone on here explain what the solution from the Reddit post was? The main topic seems to have been removed.

I’m using a Netgear Router, specifically the R6050 model.