Glitching in and out of Retribution

(Cathy Lee ) #15

Thanks Kychow17!
Do you remember if you experienced the issue in story mode, all heroes mode, or both?

(Cathy Lee ) #16

Thanks xXCODHawkXx!
Do you remember if you experienced the issue in story mode, all heroes mode, or both?


I’ve had this same issue in both Retribution and Uprising both story and all heroes mode. My router model is a Netgear AC1200. Plz help meee it’s so annoying I can’t get achievements.


mine is not router issue. i can play comp and quickplay for hours on end and not have any problems. only in the 2 new modes do i come across it every match. i dont know whats going here, but its not on my end, or at least to my knowledge


I had the issue on both

(Cathy Lee ) #20

Thanks so much for all the information guys and gals! We’re trying to reproduce the issue on our end and really appreciate the cooperation. Can you also tell me if you were hardwired or wireless when you encountered the issue?


Im currently wireless


I am currently wired


I managed to fix my issues by enabling QoS on my router I’m using a netgear R6220 router.

I’m wired.


im currently wireless


I was wireless when I was doing it, and I only tried the story mode for retribution, none of the other event modes due to the current issue.


Just an update, was able to update my firmware for my router and that with the reddit post fix seems to have worked, just ran through a game of retribution with no issues.


I don’t know if it is me maybe but for no reason during the retribution and the uprising events, when I am in the middle of the game, I will be randomly kicked and it will say client server disconnect, maybe it is a problem with my router but if there is any way to fix it I would love to because I hate having to abandon my teammates especially if we are close to winning.


I also have a Netgear AC1200 and it happens in all modes of Uprising and Retribution. I am hardwired


I have a Netgear R6230 router and the same issue where I get booted to the menu in the event every minute or two. I have a wired connection and the Reddit suggestion of turning QoS on with warcraft set at highest priority worked to fix it for me.


I updated the firmware and changed the QoS settings on my Netgear AC1200 router and still having the EXACT same issues.


Followed the instructions in the reddit post and updated my routers firmware, still affected by the issue. I have a Netgear R6220 and am wired (wireless is not an option for me).


Are there any updates for this issue ?

(Cathy Lee ) #35

Good morning!
The investigation is ongoing but I have some more information for those of you that are still encountering this issue.

Can you try prioritizing UDP ports 26503-36503 and let me know if that makes a difference.

Thanks so much!

Losing connection on Retribution/Uprising Expert or Legendary
Really high latency after retribution patch

no difference for me