Game won't launch

I’ve been trying to play Overwatch all day on PC, but when I launch the game from Battle Net it starts to load then after about 10 seconds it completely closes the game. I tried doing the “Scan and Repair” which it did end up re-installing a few files. So I tried to launch the game again and it still just closes the game. I have also tried fully uninstalling and reinstalling the game as well as restarting my computer but it still loads for 10 seconds then closes. It doesn’t give me any error message, it’s not minimizing to load (which it does sometimes) it brings me back to battle net will say “Game is running” for about 5 more seconds and then goes back to just saying “Play”. Does anyone know how to fix this?

I was able to find a solution. If anyone has the same issue and you have Razor Synapse installed that’s what is causing the issue uninstalling should let your game load (It worked for me) but specifically the file called “rzchromasdk64.dll” located at C:\windows\System32.

Thanks for following up. As for the Razer issue, the staff is aware and has instructions for a fix pinned in the sticky threads. Just in case someone else comes across this thread for help:

1 Like