Game suddenly viciously laggy, almost trying to load

rtx 2070
samsung 970 evo 2TB m.2 SSD

So i’ve always been able to play OW very well, clean 144 fps. suddenly after not playing for a few days, my game is like INSANELY choppy and lagging.

reinstalled video drivers
rolled back video drivers
shut down tons of background programs
reinstalled OW
set OW settings to lowest
relocated OW to different drives
relocated OW to my OS m.2 SSD
performed RAM memtest, no problems.

I have Apex installed on the same drive as well as spellbreak and fortnite, and those games run perfectly fine. Overwatch doesn’t seem to have rubberbanding or choppy movement, the game itself seems to be chugging like its trying to load everything. Say, when i load into the hero screen, it gets mad chunky and stopping and going, and it does it when i select characters, but once i select a character, select another character, it runs fine between be clicking back and forth between two characters.

Any ideas on how to tackle this spicy topic?


Make sure you include your DxDiag so someone can help.

I have the EXACT like literally the EXACT same problem. Also when I do like a Mei wall or shot or something its laggy, but after I did it twice or something it feels like its loaded so its less chunky… But when I switch again it feels like it has to load again and goes back chunky. I want to play the event and its just unplayable.

I played fine till November or December I think? Also I play Apex on 144Fps. Also Overwatch is on 144 fps but when something happens its suddenly going back and forth. Please can you guys check what it is cause I just don’t know what to do anymore


I run battlenet as administrator and I don’t have the problem anymore…? This is a quick update, I need to play a game just to be sure, but it seems to help…

HAHA wow, running the new weird app as admin fixed it.
Might wanna throw at one up to the app devs for this one

I have the exact same issue too, did all the same steps and still lag. Did admin and that didn’t work for me…

im having the exact same issue, ever since the new update, the game is unplayable for me. I tried running the blizzard ap as admin and that did not work for me. All of my drivers have been updated. Please help.