Game instantly closes on launch

The game has been, without fail, closing itself every time I try to launch it. It goes to the loading screen for half a second then boots me back to my desktop with no crash report or message or anything. As far as I’m aware this is a common issue but none of the “solutions” have worked for me. I have tried:

  • Uninstalling Razer Chroma SDK and other 3rd party programs (cheat engine, hamachi, etc.)
  • Disabling startup programs that might trigger the agent
  • Scanning and Repairing my game (no issues found)
  • Uninstalling/Reinstalling
  • Restarting my Computer (multiple times after each solution)
  • Deleting the blizzard cache and agent files

I’ve tried other stuff as well but above is what I can remember. I’m quite frustrated with Blizzard right now as I haven’t been able to play a game I have already paid for for an entire week because of an issue that came out of nowhere with no context and is not from my own doing.

I also should note that that I share my account with a few other family members that are frequently active on some of the other Blizzard games. One of them got their World of Warcraft Account banned recently for something and I’m wondering if that’s somehow affecting my game? I highly doubt it as they are on a completely different PC and a different game but you never know.

1 Like

Hey, Nekromanser!

Having another game license banned would not cause this problem.

Please collect a DXDIAG and post it here using the Preformatted Text button in the posting options. Just make sure the full DXDIAG contents are between the Preformatted Text tags.


To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

If your DxDiag does not fit in one message, you can post it on and provide the hash code (the numbers/letters after the .com) in your reply.

A post was split to a new topic: Azu - crash on launch

My DxDiag on pastebin

Your report is missing the end, the error section. Also, since you’re on Windows 7, my assistance may be limited because I don’t have any experience running Overwatch on Win7. You could open a ticket with the staff, though.

Hey there,

Have we already checked manually for the Razer files as suggested on this thread? Sometimes uninstalling by itself does not work.