FPS drop since last patch


#1

Since the last patch, i don’t know why but i have random FPS drop either at the beginning of a game, randomly in a game or the whole game.
I’ve been playing the game since its release at 70 fps every graphic settings on high (i can run them on ultra) and i had no problem.
I am the only one among my friends who have this problem.
My pc settings are not that bad so i don’t think that’s the problem :

  • Intel i5
  • Nvidia GeForce GTX 950
  • 8.00 Go RAM

I thought that maybe I should clean up a little bit in my pc case.
I’ve also tried to minimize a little bit my in-game settings but nothing changed.

Anyway, if you guys have the same problem or maybe a solution to this problem you’re free to react.

EDIT : Ok, a lot of things happened :

  • First, I update my drivers with GeForce Experience and optimized my game.
  • Still got FPS drops
  • I tried to clean my me PC hard disk with CCleaner
  • Still Got FPS drops
  • I followed advanced tips to maximize FPS
  • Still got FPS drops (even when I’m at 120 fps … every settings on Low)

So there’s no more solution left , I have to clean my PC case or worst, something died among my componants, maybe some RAM (and hopefully not the graphic card …)
I don’t know what to do know i can’t play the game properly …


#2

These standard tips can help resolve most Overwatch FPS drops:

Also here are advanced tips I have written in Overwatch’s Tech Support forum that maximize your FPS performance in the game.


(Nathardrick ) closed #5