Error Applying Update - Unknown Error

Exactly same problem here.

1 Like

we need this problem solved fast before the event ends!

3 Likes

It still says my current version is 1.39. I have checked for updates, and it says that my game is up to date despite it not being the current verion. I am unable to connect to the game server because of this. I have run scan/repair, and it says no issues found.

Same issue, reinstalling overwatch didn’t work, reinstalling battle.net did not work. restarting my computer 3 times did not work. It’s stuck in an infinite checking for update loop for me.

Same. Can someone fix this sh!t?

3 Likes

Hey all,

We would like to collect additional information on this issue. Could affected players please collect some log files and email them to Techinfo@blizzard.com with the subject “Overwatch is not picking up the 1.40 update.”

Note, this inbox is only for submitting files and emails do not receive a reply. For replies from support agents please post on our forums (here) or contact support.

These files will help us better identify the cause of the error so we can resolve the root cause. Please and thank you!

3 Likes

I have the same issue on ps4… any suggestions?

2 Likes

Same issue, BUT, I was able to connect to the EUROPE server while using a VPN and it worked.

Doesn’t seem to be a client problem…

EDIT: just tried a Check for Updates from Battlenet and it never ends… always looking and looking… looks like an Update server issue to me.

wanted to jump in and say i have the exact same issue and was able to find a temporary fix in restarting my computer or deleting the battle.net files. after doing one or the other i still saw the applying update banner but i was able to join and play matches normally. the fix ended when i closed the game entirely and i was back to disconnecting when i restarted.

me 2. i had this 2 time in comp. and it mean 100 sr lost !!!

after doing this again game fail and unknown error 2 appear, its happen on comp !!!. its not fair… so an annoying. i really had hard time to climb up. and now i lost 150 sr and that means i should win 7 time to reach where i was

There is difintely some server side issue

Penalty #3, all caused by Blizzard server issue :rofl:
Tested EU server, broken too

You said impossible to rollback all penalties, but you can’t fix your servers too. So 1:1, time to rollback

Three days in a row:

Unknown Error (-5) error applying update

I see this error happening on consoles too:
it cant be user side problems, but Bliz support can answer. Maybe on weekend already :poop:

3 Likes

Yeah i tried VPN in every location and it wouldn’t work. It’s definitely Blizzard side but they don’t want to acknowledge it so people will continue losing SR and getting mad about this.

Hi there,

I keep getting an error applying update -1 when trying to join a game then disconnects me from overwatch servers.

Issue details:
If I try to play a quickplay match, or comp, or even the training level, it shows entering Practice range then after it shows
“Applying update” for 10 seconds then says “error applying update” “unknown error -5”.
Then it logs me out of my account.

Playing from Canada.
Issue is on live US server, Europe server works using VPN.*
I tried connecting from Austalia (VPN) on USA server and same error.
I tried repairing the game: No error found.
I tried to delete the Blizzard Entertainment cache folder in %programdata%. no go.

I had that yesterday at around 10pm eastern.
Now it’s 1 pm and I still got the error.

NOTE: I did play a few matches without Battlenet running. To do some fps improvement tests. (End proccess for the agent and crashmailer…)
I also deleted all instances of the Battlnet Agent exes in the appdata local and programdata folders.
Battlenet redownloaded the agent. Still, same issue…

EDIT: just tried connecting to Europe server through Paris (vpn) and it worked! (200ms ping…)
It shows the “Applying update” message then it goes into the match.

EDIT 2: just tried a Check for Updates from Battlenet and it never ends… always looking and looking… looks like an Update server issue to me.

1 Like

i have the applying update message, but it didnt fail, it just keeps popping up the first game i load into in a sitting, since about this time yesterday.

Edit: its now popping up everytime i load into skirmish or a game, but it still hasnt failed to update, just makes the load in take a few seconds longer.

2 Likes

I have the same problem, connection from EU Servers (im based in Switzerland). I have tried everything I can but nothing helps.

1 Like

EDIT: just tried a Check for Updates from Battlenet and it never ends… always looking and looking… looks like an Update server issue to me.

i was going to try that, guess i wont now! lol, still getting it, may take the rest of the day off of ow till we get a reply.

just a little info, im in eastern ontario canada, i dont think its an area issue but figured id add that info.

1 Like

Not an area issue. Getting same error in Southern California.

1 Like