Day 2… still can’t even get in

This is really bad guys. I am starting to feel like I wasted my money on the watchpoint pack. The original was my favorite game. I enjoyed the beta. Now I can’t even enjoy a game I’ve been waiting months for. Thanks for nothing blizzard.


I’m on the same boat as you, I put 6 years of my life into Overwatch. I unlocked everything and now I can’t even login. With a fear of also losing everything I worked for too.


Same here, ive been trying nonstop all day on my ps4. No progress. But my pc loads it in just fine…

Also the DDOS thing seems like an excuse. Even if true, it doesn’t explain the total failure to give make sure that people had their prepurchased Watchpoint Packs at launch or to make sure that account merges for console went smoothly. Just a total failure in multiple ways.


I can’t get on PC or Console been trying since launch yesterday and never got in once


Can’t login either since yesterday on ps4. This is ridiculous.

1 Like

I’m also unable to get in on Day 2. 1999 players have been ahead of me for 10+ minutes.


Yeah about those queue times,… Why does it seem they drop 1000 in 10 minutes than 100 every 5~10 minutes? Okay yesterday was a complete disaster of a launch. They should have had top server folks working on it over night. However it would seem that is not the case.

Was in earlier, didn’t take more than a 2~3 minutes to get in. Logged out to eat. Now I sit waiting 2000 players ahead of me for 10 minutes??? Really are the servers full??? Maybe add a few more servers??


Day 3… still no entry on console! EDIT : Shortly after posting this, i eventually got in, though down for maintenance, we still got in… lets goo!

Blizzard is a bad company that makes good games. Nothing ever works at the launch. Maybe except the cash money Mobile Diablo

Here is a thread I created 7 hours ago where we have discussed about us not being able to get in and constantly getting error LC-208. It’s very active too. Feel free to read our frustrations or add your own:

Me either. They say things are getting better. Still haven’t gotten in even once to see if my stuff transferred or not.

Same here man series x and wifi that can has 400 mbs download speed. They said they’re starting to stabilize but it doesn’t feel like it

Agreed. It’s definitely not stable at the moment. They did update the post:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.