Constant disconnecting during competitive!

Hi. I’m extremely disappointed and figuring out why I’m constantly getting disconnections during my competitive games. Both times were winning matches. My internet was fine as it was running in 5G. For the meantime, I tried accessing other websites to ensure that it wasn’t my problem, and came to a conclusion that the problem is your server. This is such a big issue for me and causes me and possibly other players unwilling to enjoy your game. I am constantly left in “connecting to game server…” and “entering game…” state and a minute later, having to type my credentials over again. This is such a nuisance and have lost 120 hard-earned SR for absolutely no reason. Adding to the frustration, is a suspension which has now racked up to 51 minutes - once again, for absolutely no reason.

I would love to continue playing your game and consider all the hard work you’ve put in your game but after what just happened, I’m slowly losing the motivation in trusting and playing your game.

I’m having the same issue right now as well. It kicks me off randomly and I’m not using WiFi to access.

Im having the same prob, even kicking me off QP !!!

Troubleshooting can be offered here once a network test is provided. Instructions at top of forum: Common Technical Issues and Solutions

Is this 5G referring to WiFi or referring to a mobile broadband connection? If it’s WiFi then using a cable to test the connection is recommended.

Referring to my WiFi, but I have also tested connection using an ethernet cable. Same results. I wanted to wait it out awhile and have been playing more on QP but same issue still arise. I cannot see myself confident enough to continue on with competitive if this issue keep re-occurring at random times!

In that case, make sure to add a connection test. Instructions pinned at top of forum: