Chroma App not working correctly

Recently upgraded my PC to Ryzen/MSI X370 Gaming Plus. I noticed my Overwatch Chroma App was not working so I found an entry in Razer Synapse for my motherboard and ledkeeper. I disabled them which got the Overwatch Chroma App effects to show up but it seems to be competing with the current lighting profile which causing excessive flickering. Using Razer Synapse 2.21.

Can you please update to the latest version of Razer Synapse at https://www.razer.com/synapse-3

I already have the latest Synapse according to Synapse as it finds no further updates. I am on 2.21 and SDK 2.10. Synapse 3 does not support the regular Blackwidow Chroma and is still classified as beta.

Hi there xARKHIRAx,

While the Beta is a Beta, Razer knows of this crash issue with Overwatch and other games caused by Chroma. The beta Chroma SDK is the fix right now as Razer made the effort to fix it.

Maybe the beta will be pushed out soon, but if you would like to not have issues, the only options are to no use the incompatible Chroma SDK. I am sorry for this bug and hope the fix they have is pushed out soon!

/Nathardrick

Hi all,

Just experienced the same issue when I updated to Razer Synapse 3. Chroma lighting was not working when playing Overwatch.

To get it working again I uninstalled Razer Synapse 3 and reinstalled Razer_Synapse_Framework_V2.20.15.1104.exe.

Lighting for Overwatch worked immediately :smiley: Trying my other games now.

BTW I’m using a BlackWidow Tournament Edition Chroma.

Hope this helps.

To run the chrome razer in overwatch without any problem you need to close the razer synapse 2 (I use it and I have no problems in the game) then you go into the control panel, uninstall then uninstall the chroma sever SDK. Then start the razer synapse 2 synapse 3 and it will make your chroma profile! I hope I’ve helped you!

We actually have an external post on this at this time. You can check this out for the full rundown. Since this thread is 5 months old, I’m gonna go ahead and lock it, but thanks for sharing your experience anyway!