Can't update game since a certain patch


#1

Hey,

problem: doesnt let me update
I cant play since a patch a while back, so i took a break only to come back and it not being resolved yet, so its on my end i suppose? I followed all the steps at https://eu.battle.net/login/sso?token=EU-b6a291b3c69d5dcaa21f8900f314d85b-419527483&ref=https%3A%2F%2Fnydus.battle.net%2FApp%2FenUS%2Fclient%2Ferror%2FBLZBNTAGT00000840%3FtargetRegion%3DEU%26code%3D2112&blzcmp=app

Only not to find any solution, tried every step and even the advanced ones.

And yes i totally removed the game and battlenet and reinstalled both

help please:)


#2

For step 3 regarding security programs, did we uninstall or disable those. If you are running third party security programs, which ones are you using?

Do you have the option to test with a different network? Maybe a mobile network if you have a phone and data plan that supports tethering. If you have data limitations we don’t recommend updating the entire game on the mobile connection but we can use this to see if the download even starts.


#3

Regarding step 3 it was just disabling which was MBAM and the other being the windows defender itself.
I have tried all kinds of stuff like exclusions and more.

I do not have any way to test it on a different network.

Is there anyways to look up logs on the launcher?


#4

Daxious,

What error message do you get when trying to update the game? Can you trigger the failure, write down the error code, and post it here with a DXDiag? You can generate a text copy of your DxDiag using these instructions. Once you have that made, open the file. You’ll need to copy and paste the contents of the Text document into the post using the “Code” button (</>). This will give me some more information which I can use to dig deeper into this case.


#5

paste bin , cuz too long sorry S1zKAvgW

iyfsVUX imgur is the error :smiley:


#6

Daxious,

Okay, 840 is a file modification/permission error usually. Since you’ve tried so much, I still want a complete DXDiag to look for more options. There’s a bunch of stuff missing in the DXDiag - can you try re creating the dxdiag and making sure not to delete anything, and double check the imgur link?


#7

DXDIAG: pastebin/ZvNd4sdu
Error : /rrfGuMq

I’ve copied everything from dxdiag.


#8

Not seeing too much that stands out. For further troubleshooting I’d recommend putting in a ticket here making sure to include the DxDiag and MsInfo report. With that we’ll be able to look into the issue in more detail.