Cannot Open Overwatch

So, I’ve been trying for the past hour to open OW.

I’ll open up the blizzard app, press play then it’ll open up the loading screen. A split second will pass, and it shuts down OW. Everything else is works, but for the main issue. Basically showing a black screen, then just logs off. Like I haven’t even opened OW.

I ran a scan and repair, everything seems to be working. I logged out and logged back in, nothing works there. I restarted my laptop, nothing works. I did a clean reboot just in case something else was wrong. I opened up some other games, they work just fine. But for some reason, I cannot open OW or play it.

Please help this dumb gamer girl. I just want to play with my friends.

With any technical issue, please include a DxDiag for troubleshooting.

DxDiag instructions (click to expand/collapse)
  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save.

To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

Note: If your DxDiag does not fit in one message, you can post it on Pastebin.com and provide the hash code (the numbers/letters after the .com) in your reply.

Note: I’m an MVP/volunteer, and I don’t work at Blizzard. :stars:

I am not allowed to post links. Is it possible for me to send you a PM?

Per the instructions, you only need to give the end of the link, the hash code after the .com. There is no PM feature on these forums.

I totally misunderstood, my bad!

HJfi8pfn

The launch issue can probably be resolved by following the steps here: Known Technical Support Issues - [Updated May 18, 2019!]

I will also note your GPU drivers are about 7 months old, so it will help to update those as well. You can update via the GeForce Experience, and make sure to choose clean install.

You are a god send! Thank you so much, I truly appreciate your help!

You’re welcome, glad that fixed it. :slight_smile:

Last night, I though I got it to work. But it turns out it didn’t work. I did everything that that listed, and I still get the crash. I haven’t reached out to Razer yet, but I figured that you would be 100% more helpful.

Look for and delete these files:

C:\Windows\System32\RzChromaSDK64.dll
C:\Windows\SysWOW64\RzChromaSDK.dll
C:\Windows\SysWOW64\RzAPIChromaSDK.dll

I’ve deleted them, but I still get the crashes. I’ve sent out a help email to Razer, and I’ve heard nothing from them so far. Made sure to double check if the files have been deleted. Thank you so much for being so helpful, you’re a true gem <3

Can you run another dxdiag and post it on pastebin again? You might also look in the Windows Event Viewer and see if there’s anything happening under system logs. Anything marked with a red exclamation point.

y58S3y6G <—for pastebin

I checked WEV and nothing showed up with any red exclamation.

It’s still showing up as what’s giving you an issue:

Problem signature:
P1: Razer Synapse 3.exe

You may need to work with Razer on this one

Edit: Did you try the beta version? That might help.

Okay! Thank you so much for your time. If I could pay you, I 10000% would. I would tip you in your favourite treats. I hope you have a fantastic year <3

Sorry I couldn’t figure this out for you