Cannot join friends due to differing versions of the game

I just updated to Overwatch 2 but it says I can’t join my friends. They are in a party and playing just fine but I can’t join them. I check for updates but I’m up to date. Any ideas?

Update: I Reinstalled and sat in queue hell for like 2 hours then it randomly started working.
Update 2: Happened again. Reinstalling wasn’t a permanent fix.


bump, same here. I was running OW2 just fine, I exited to see if there was an update to play with my friends and there wasn’t one. Logged back in, waited in the QUEUE, and still unable to play with my friends due to different version of Overwatch. Ran a scan and a repair to no avail.

same for me…cant join friends

Same! This is happening with a friend of mine.

this is happening to me as well, looking for a fix :confused:

1 Like

Having the same problem. It’s weirder because one friend finished queuing right after me and I was able to group with them fine. Next friend finished queuing shortly after and it refused to let me invite them due to this error. They restarted and have been in queue hell since. Another friend (who queued at the same original time as the rest of us and ran into 3 queue disconnects and had to do 3 queue restarts) was able to join my group ~30-45 minutes later without issue. Then another hour passed and another friend who queued later got the same “version” error and can’t join us now.

Bump. Same thing happening to me.

Having this issue as well, even after a fresh uninstall, restart, reinstall. In that order.

We’re all running the same version of the game.

Same here. Just giving me different version error after being in queue same time as friends.

We’re in the same region, same version. But client still thinks we’re in different versions of the game for some reason.

Only about half of my friends I see are available to invite to group. The other half are in game, but greyed out option to invite.

Same here really annoying . my friends list is completly empty too

Same, says can’t invite or be invited due to different version of overwatch. I tried reinstall and no luck

Hello, had the same issue, found on reddit this fix:

type in chat the following:

/invite name

name is your friends name



I have this issue as well. The way me and my friends have fixed is by going into a game browser together. Let the game end and the leave. After that you want to unfriend each other then one invite the other from the “recent players” category. For some reason you can invite recent players, but not friends right now. I hope others see and that this helps, but this has worked 100% for us.

1 Like

They should just delete overwatch 2 permanently and bring back the original. The original was doing fine. I want my money back.


Having the same issue atm. Though, now we can’t log back in XD

Edit: already scanned and things were okay.
haven’t tried reinstalling, but that’s a lot for a game that likely won’t let me in for a few hours haha

1 Like

Thanks this solved it for me!

Worked for me too, thank you.

this worked for me too. this needs to be pinned for others

One fix that we’ve found is removing your friend, and adding through recent players… lol
So, search at the same time, hopefully get into the same game, then remove friend and add to group.