Blurry Crosshair at 1440p


#1

The crosshairs at 1440p are a blurry mess.

Can this be fixed please?


Previous posts on this issue:



#2

Yessssssssssss please someone talk about this!!


#3

Yeah it maybe a scaling issue with the U.I.

Here is a zoomed in version of the crosshair in photoshop https://i.imgur.com/fFs5MBB.jpg


#4

Here’s what it looks like for me. https://66.media.tumblr.com/94e8a9f3ec11df9736010db7ba0b6089/tumblr_pfkp17x4I11tc8dtgo2_r1_500.png

It definitely feels like a scaling issue and I tried for 3 months to figure out what settings I needed to fix before realizing… There’s nothing I can do. Blizz has to optimize the resolution.

I don’t know if it’s because my monitor is 27" AND 1440p and Not a widescreen (Default aspect ratio is 16:9)

Support basically told me “I told the devs about it but to fix it you can play with a lower resolution” But it doesn’t fix it because then I have black bars around the game.

I can run the game in 21:9 and it fixes the UI scaling but it also adds black bars around my game because I don’t have a widescreen monitor. And it makes my sens feel different.

Running the game in my default ratio of 16:9 causes the ui to be blurry and big. Hit detection and input lag also feel bad.

TLDR: Please let us play in our default 16:9 aspect ratio at 1440p resolution on a 27" monitor. I don’t want to buy a new monitor just for this game to feel good.


(Bill Warnecke) #7

Hey there, sorry for this issue. One of our UI engineers is taking a look at this and we think we may have a solution to work around this. Unfortunately it may not make it in until the 1.32 patch.

Cheers.


#8

Thank you.

On 1080p the crosshair also get blurry when playing in windowed mode, going fullscreen makes the outlines crisp again. Been like this since launch.


#9

Hey Bill i just a something to bring to you that i have found about i was watching a twitch streamer just before and notice that when they were playing tracer they didnt have the circle that get a little bit big when they shoot but instead that just had four lines as a cross-hair and there was no fire spread i have taken a photo from the streamer and then a photo from my game to check the difference so if i can send then to you to help let me know


#10

They probably have custom crosshair with Bloom turned off. (You can customize crosshair in options-controls and click on the “+” sign under crosshair :wink:)


#11

You can’t just ugly-hack it in?

and my recollection of how ResizeBuffers/ResizeTarget are called makes me feel you could just stick a view-matrix recalc into the WM_SIZE handler? I mean, you always seem to be calling ResizeBuffers() from there, unless I remember things backwards…

Just a suggestion, hoping you can ship a small fix in 1.31 :stuck_out_tongue:


#12

Awesome! Looking forward to the fix.

Ideally, I’d like to be able to have 1px (native) crosshair width at 1440p.


#13

Another thing at 165hz is that kill-cams lagg, it looks like the player who killed you is using cheats.


#14

Just tested it on the PTR! Super happy. It’s the new “Scale with resolution” setting in where your crosshair stuff is :slight_smile:

I do wish the game didn’t scale soo much since hit reg feels a lot better when the enemies are smaller/normal sized… but I understand the FOV issues.

Still really grateful to have a nonblurry crosshair soon <3