Black screen after clicking "play" button

After the “Summer games” update I cant launch the game. Whenever I do it I have a black screen. I tried repairing, reinstaling, updating my drivers (up to date), updating Windows, uninstalling razer Synapse 2, installing razer synapse 3.
Nothing worked so far. Before the update came I’ve been using Razer periperals for along time and never had any issue so I dont think it is a problem. Pls Help!
Dxdiag -

Hi there. First, you may want to remove your MSInfo, as those should only be shared privately in a ticket with the staff.

I think the Razer issue is still affecting you, because the software is continually crashing in the background:

Podpis problemu:

P1: Razer Synapse Service.exe

Check the steps here, and see if they help:

I uninstalled all Razer software, manualy deleted remaining files in Program FIles on my C drive, did a registry clean with CCcleaner, restarted the computer. Tried to start the game ( black screen), installed Razer Synapse 3, started the game (black screen), unchecked dectction of the game in Chroma apps (still black screen).

As I was saying the game worked fine till yesturday update. I have been using razer synapse 2 over a year with no problems before.

From what I read the Razer problem is when the game starts it turns to black screen then closes itself to the app. Mine stays in black screen untill I manually close it. Dunno if its important or not but DIablo 3 works fine with the Chroma unlocked.

You may need to open a ticket where they can look at more reports (which you don’t want to post here). They can help you find any remaining files that might be interfering.