Anyone else lock up launching OW2?

So, has anyone else’s PC locked up when launching OW2 after yesterday?

2 days ago, the game would launch fine; Now, the game takes 5+min to load and I can’t open anything else on my PC until the game window comes up.


Happend the same to me, I tried many different thing but nothing worked, I left it loading and it opened after 5/10 mins each time, I really hope they will fix this thing, it’s pretty annoying for the pc to freeze like that.

1 Like

Yes. Left it running, and it eventually loading correctly. Put in a ticket and got rubbish auto response… Like I’m really going re thermal my cpu, everything else runs fine.

Same, PC freezes, also tried everything, can we get this fixed please?

1 Like

Yep. I have no idea what’s causing it. I tried uninstalling and reinstalling on a different ssd.

1 Like

I’ve tried all the troubleshooting steps and it freezes my PC and eventually loads after a few mins.

  • Reinstall drivers
  • Reinstall the game
  • remove saved video and settings

yes, the new patch has made the game laggy/freeze

they will just use a canned response and close your ticket

no help at all.

I think it happen after new random hero comp was put in?

Sorry to hear a lot of you, like me, are experiencing this issue. I have no idea, nor have I been able to figure out any fix so far.

*Updated drivers to multiple previous versions and the newest version of Nvidia
*Updated Windows, just in case
*Closed every open program before launching the game

Nothing I tried seemed to work…game launches, it just takes 5+min and freezes my PC while doing so.

Will post if I hear anything, guys. Stay strong, hopefully Blizzard sees this one.

THIS. this is exactly what’s happening to me. I thought my PC is going crazy. I’m on AMD system (Ryzen+Radeon). Anybody with the same system too? and is it relevant? if not, what’s your system?

Dealing with the same issue. Last logged into Overwatch late 3/13. Assuming it’s due to the recent patch? i9-10850K / RTX3080TI system.

Other Bnet launched games launch and run properly.

Once clicked, the blue Bnet button says “Playing Now”. For whatever reason after clicking, it also prevents other applications from opening, including my Control Panel and other base-Windows applications. I’m then required to hard restart my PC.

I’ve run “Scan and Repair” via Bnet launcher and uninstall / reinstall. All drivers are up to date and running the most recent Windows updates. *EDIT - Running 22H2 (Windows OS Build 19045.2728)

First time experiencing this issue with any Blizzard titles / Bnet applications. Hopefully a fix is implemented soon.

*EDIT 2 - After a few more tests, Overwatch eventually opened after approx 2 minutes, along with the other applications that I was attempting to open while waiting. The game appears to be running properly, but really strange.

Same deal here. Ryzen+Nvidia here.

1 Like

Gotcha. ryzen is what we have in common but I doubt that’s the culprit. Are you on Windows 11 too?

1 Like

Same issue, but my game won’t open even after 15 minutes or more. I have to exit overwatch or battlenet.exe in task menager or restart my pc :confused:

My troubleshooting was almost identical to yours, and I got the same results, apart from with diminished in game performance (usually solid 190fps down to 50/60 with spikes)

Hey everyone,

Thank you for reporting these sudden issues with delayed launching. This behavior with the client is commonly caused by outdated antivirus software, so be sure that you’ve fully updated security software you have installed. If that doesn’t work, try temporarily removing the security software, then reboot your computer and retest.

Note: Some security programs may be difficult to uninstall. ESET maintains a comprehensive list of common antivirus uninstallation tools on their website.

intel i7-6700k , gtx 1070
bitdefender anti virus free - updated
window defender
windows 10 home / 22h2

This is my exact situation ive updated all drivers, installed fresh windows, thought my PC was bad so bought a new SSD. put the game through exceptions in my antivirus nothings helped.

This started for me just a couple of days ago also. The problem appears to be with CrashMailer_64.exe. If I delete Overwatch/retail/ErrorReporting/x64/CrashMailer_64.exe and hit “Play”, the game launches immediately and plays fine. Unfortunately, the next time I start, it restores CrashMailer_64.exe and the problem returns so I continuously have to delete it before playing.