An error occurred with some file. We are sorry


#1

I stopped playing OW back in 2017. I enjoyed it greatly but since I have a metered connection and this happened right after a large update I was told to “Download it again”. That was not an option back then so I stopped playing instead.

I tried again at some point in 2018 but the update failed yet again…

Now it is 2019 and I want to play again so I downloaded it over my metered connection again and after downloading more than 16Gb in a day the last 115Mb won’t download because “There was an unknown error with a file. We are sorry. We don’t know why this happened. Click here for some troubleshooting tips”.

Note that nowhere do they ever say WHICH file the error is on… always just “a file”. That’s very helpful indeed, isn’t it? :frowning:

  1. Since I managed to download the other 16GB+ yesterday I thin it’s safe to say my internet is not the reason why the last 115Mb can’t download. I deleted the installer as instructed, ended the agent task, disabled Windows Defender, ran the file scan and fix option from the launcher(only to be met by the same error.Can’t scan whichever file because there was an unknown error on “a file”), ran the installer as Admin and, of course, turned my PC off and on again and disabled other applications running in the background.

Yes, my drivers are up to date as I am rather fanatical about that and Windows is set to always check for updates (metered or otherwise).

It’s going on 18 months now and I am back to having uninstalled OverWatch and having to download the entire 16.8Gb again for the second time in as many days over my metered connection and not expecting to get anywhere thanks to this track record :frowning:

Please advise. Thanks

P.s. Before I could download OW I first had to wait for the launcher to update but when it runs I see it is a 32bit app. Is that supposed to be the case or is there a 64 bit launcher available?


#2

Is there enough space for it on the drive? Does it have the proper permissions to write the downloaded content to it? Does your account on Windows have permission to install applications?


#3

Do you have a separate route and modem? If so can we try connecting directly to the modem then run a scan an repair on the game?

Otherwise is there a different network we can try downloading the last bit on? Maybe a mobile connection if you or someone you knows has a phone with a data plan that supports tethering? We’ve seen similar behavior when downloading games on school networks and generally testing with a different network or a VPN is the workaround for this.