Stuttering Nonstop framerates drops game unplayable I've tried everything i can think of PLEASE HELP

I’ve been playing hots for the past 5 years and have never had an issue until a few days ago.

I started getting stuttering in-game where ill get green arrows all over my screen for a second then like teleport somewhere. I get frames of like 200+ down to 10-20 then back up consistent ping of like 50-60ms. It happens in try mode as well as custom games vs all ai enemies on lost cavern.

I’m pretty sure it is not my internet but I am in an apartment and can’t run an ethernet cable, unfortunately. I do use powerline adapters. Nothing else seems to be lagging for me and I get good speeds and no lag in anything else I play.

I have tried:
-deleting cache
-updating Nvidia 1070 drivers
-checking to make sure windows 10 is up to date
-changed in-game graphics to restore the default.
-disabled enable reverb (found this on reddit as advice)
-restarted cpu
-rebooted router and modem
-reconnected powerline adapters
-ran hwmonitor while playing and nothing is running hot

I’ve done everything I can think of and I’m freaking out because I’m on an NGS team and the new season is starting and I need to get this fixed.

Please Help

Hope you get a reply dude, people are probably gonna ask you to post MSINFO, DXDIAGF, Looking-Glass and Pathping logs.

Anyone? please help.

Hey LosT,

Lets try this. Sometimes stuttering issues can be caused by a problem with the driver install.

  1. Download DDU here
    • Click on the first link under “Announcements” titled Display Driver Uninstaller (DDU). Then click the “Official Download Here” link to start the download.
  2. Run the .exe file and extract the contents to the default location. Open the new folder and run the Display Driver Uninstaller.
  3. You will get a pop-up saying it is recommended to reboot in Safe Mode, feel free to ignore this if you are not familiar with how to get into Safe Mode. To start the removal process, click on the driver type on the right side first, then click “Clean and restart”
  4. Once the PC restarts, go ahead and download the current drivers here: https://www.nvidia.com/en-us/drivers/results/163531/
  5. Run the driver installer and use the default/recommended install steps.

Test the game again. If you’re still having issues go ahead and run a WinMTR test so we can double check the connection for any issues.

  1. Download WinMTR
  2. Right-click on the downloaded .zip folder and select “Extract All”, to extract the files to a new folder.
  3. Open the new WinMTR-v092 folder that was created, then open the WinMTR_x64 folder.
  4. Right-click on the WinMTR application and select “Run as administrator”.
  5. Type the server IP 24.105.62.129 in the “Host” field. Click “Start” to begin the test.
  6. Launch the game and join a match. Allow the test to run for the full duration of the match or at least 10 minutes, then click on “Stop” when you’re done playing.
  7. Click on “Copy Text to Clipboard”, paste the results here, then highlight everything and hit the </> button in the posting section so it will allow links.
Ok I have tried the first one with little to no difference so im moving on to the second one right now

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                              10.160.0.9 -    1 | 1459 | 1456 |    5 |   15 |   51 |   17 |
|    gateway2-BE6-eph3blocal1.eph.ptd.net -    1 | 1459 | 1456 |    6 |   15 |   47 |   11 |
|        gateway-be9-chi2wb32.chi.ptd.net -    1 | 1458 | 1455 |   39 |   48 |   77 |   44 |
|                eqix-ix-ch1.blizzard.com -    1 | 1455 | 1451 |   39 |   52 |  138 |   44 |
|                   No response from host -  100 |  296 |    0 |    0 |    0 |    0 |    0 |
|         et-0-0-1-pe01-eqch2.as57976.net -    1 | 1466 | 1465 |   38 |   51 |  159 |   45 |
|                           24.105.62.129 -    1 | 1455 | 1451 |   40 |   49 |   79 |   45 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Heya LosT,

That winMTR shows some pretty hefty stability issues at the beginning of your test. You’re mentioning that you’re on powerline adapters. Can you temporarily move your setup nearby your router, wire in directly, and see if it fixes things? if it does, it means that the powerline adapters have too much interference (which is somewhat common for this kind of adapter.) You may need to find a different way to configure things to avoid this behavior if that works. This can be a bit complicated depending on your house setup, but in some cases it may be the only option to prevent this kind of jittery gameplay.