SOLVED - Game does not Save Settings - Many Fixes Tried and Failed

FINALLY AFTER HOURS OF SEARCHING AND EXPERIMENTING (and no thanks to the silently useless tech support blues):


You have to disable your Windows 10 Controlled folder access.

I’d post the link from Windows Support, but I suppose these silent tech support blues just want us to stay safe from malicious links, even if it means we random players get screwed and ignored for long periods of time.

So just Google: “Allow a blocked app in Windows Security”, and follow the instructions under “Use controlled folder access”

Found this solution from a post 2 years ago. If the blues aren’t going to comment on this issue anymore because it was “LOLSOLVED”, then please sticky this somewhere, as it’s very annoying and tricky to solve unless you luck out and happened to find this post…

Taken from another post that has yet to get an answer from Blues… I am experiencing the exact same issues.

I am unable to save any of my setting in game. No Quickcast settings, and graphics reset to default every time I step into a match. The intro movie ALWAYS plays on startup. Hotkey setting don’t save when I change them during a match either. Creating new hotkey profiles in game does nothing.

I’m running on Windows 10.


  • Scan and repair did not work.

  • Uninstalling and then reinstalling did not work.

  • Giving full read/write/execute permissions to the “Blizzard” and “Heroes of the Storm” folders did not work.

  • Turning windows firewall off did not work.

  • Running the program as an administrator did not work.


  • Did another full reinstall with an uninstaller app to clear the registry, and manually deleted all residual files in the documents folder… Still can’t even make a new hotkey profile.

  • I have also confirmed that Microsoft One Drive is not currently installed on my computer, nor is there any other cloud service running.


  • Changing the compatibility setting of the BNet launcher and all Heroes exe files I could find to always launch as administrator. Still no success

  • I have not used my Bnet account on any other machines since I upgraded my computer 2 years ago.


Awesome! Totally worked. Many thanks! :+1: :metal: :love_you_gesture:

1 Like

I’m very pleased to see you this worked for you as well. It was quite the hunt >.<

1 Like

Solved my problem too. Thanks! :slight_smile:

I’m having the same issue, but I’m on a Mac so I don’t have a Windows 10 Controlled folder access to disable. What do I do?

1 Like

Same issue on a mac, any solutions?

1 Like