[Monterey] Mic not working for voice chat on HOTS

Hi there!

I can’t get voice chat to work.
There’s an issue with Heroes of the Storm not having permission to access the microphone.

I already tried going to System Preferences > Security & Privacy > Microphone, but the problem is that HOTS doesn’t even show up there in the list of apps. Battle.net does show up and I can “test” voice chat in Battle.net and it works but, again, HOTS simply doesn’t even show up as an app to give access to.
I already tried uninstalling and starting anew but still no access request from HOTS nor does it show up in the Security & Privacy settings, as mentioned.

I tried a solution posted in this forum (the thread is called “[Catalina] Voice Chat not working in Heroes of the Storm” and it was posted by Zentgraf, you can Google all this) which is basically adding permissions for HOTS to use the microphone directly into the permissions database, but the solution there is made for an earlier version of MacOS (Catalina) and it doesn’t work for Monterey. Basically, that user suggests updating the ‘access’ table in TCC.db, but the query provided doesn’t work since the table structure has changed as the OS got updated. Namely, the fields are not the same.

An article in Rainforest QA named “A deep dive into macOS TCC.db” (you can also Google that one) provides details on how the table changed with the Big Sur update.
However I’m not savvy enough to take the suggestions made for Catalina and adapt them to the new table structure in Monterey.
Can someone please help?