Game doesn't auto login

Recently, I’ve been unable to auto login as usual from the battlenet app. It used to just log me in automatically after I click the play button but now it just opens HotS and ask me for my password. I already tried scan and repair as well as uninstalling and reinstalling and deleting the HotS folder in documents. Is there a way to bypass this annoyance?

2 Likes

The same is happening to me since the Caldeum patch hit.

Yep…same here. No auto log in and keeps requesting mobile authentication even though I set it up to remember this desktop or whatever setting it is.

Hey there,

Lets try a reinstall of the desktop app. There could be some file corruption with where your login is stored causing this. The reinstall should fix it if that is the case.

I’ve uninstall, deleted battle.net folder from programdata folder, and still, i can’t get auto login. Any other fixes?

I haven’t been able to auto login for awhile now. Recently the game logs me in as a blank screened account, so I logout in game, and after I re-login, it says “ERROR you were disconnected from blizzard services.” This only started happening after the Caldeum patch.

I had the same problem.

4/12/2019 7:27 PM MDT
Uninstalled battle.net app
Deleted
AppData/battle.net
AppData/Blizzard Entertainment

Installed battle.net app

Successfully logged in HoTS.

Update:
4/12/2019 7:33 PM MDT
Exited the game and closed the battle.net app.
Upon opening the battle.net app it asked for my password and authenticat again and asked for password in game as well.

Hey everyone! Thanks for the reports on the auto login issue. Out of curiosity, does this persist on a New Admin account after the first launch? This resets a ton of functions and permissions, and can help even if there is already an administrative account on the system.

If this works, does it persist with secondary logon enabled for the primary account?

Other than this, is the Blizzard Application or game installed on a different hard drive than the main OS drive (by default, C:\ Drive)?

A post was split to a new topic: Edvardiko - Game Not Auto Logging In Thread

Tried both, still not happening. This is now also happening with SC2.

Hey man, I did three things and now AUTOLOGIN is fixed.

1 I clicked on my game in BNET, and ran SCAN AN REPAIR
2 I exited BNET, then right clicked, and RAN AS ADMINISTRATOR.
3 I checked windows for updates manually in settings, but it said it found nothing

Now AUTOLOGIN works, even if I dont run as administrator. The game seems to load very fast too… not sure which thing fixed it, I dont think scan and repair did anything but not sure

Thanks for the report! We’ve been seeing some similar behavior with StarCraft II where clearing some files helps.

If you are running into the auto-login issues, please try a Scan and Repair, as well as the steps provided here.

I had this problem for a LONG time and I’ve found the absolute solution.

  1. Launch the game from the heroes executable “Heroes of the Storm.exe”
  2. Login in the screen that comes up, which will bring up the launcher afterwards.
  3. Launch the game from the Launcher.

This will save the credentials Heroes needs to automatically log in next time.