Black screen on login


#1

I just got my laptop back from being repaired the hard drive was damaged due to dropping it. When I got the laptop back I reinstalled HOTS but when it launches all I can see is a black screen with the cursor nothing else. I’ll leave it like this for 5 minutes but nothing happens. I’ve reinstalled the game and made sure my drivers are up to date several times but this keeps happening.

Any suggestions on what to do?

My graphics card is Nividia GTX 1050

i5 processor 8300
(apologies if this has already been posted before)


#2

First try renaming Documents\Heroes of the Storm\Variables.txt so that the game is restored to default settings.

If it still occurs try changing the displaymode setting within the new file to displaymode=2 while making sure the height and width settings are set to the native size of the laptop display.

Make sure that both NVidia and Intel graphic drivers are up to date. If that does not help it might be a good idea to try an older NVidia driver since some people have reported issues with them since the versions that added RTX 2000 series support.


#3

I’ve tried doing what you’ve said but when i rename Variables text the game launches and I click on the screen it goes black again .

What would be causing this?


#4

Hello laughingfox!

Sorry to hear you’re running into these black-screen issues… are you using any Razer software, perchance? We’ve seen issues with several games with black screen on launch, due to a fault in the Razer Chroma software. If this is the case for you, please try uninstalling any Razer-related apps and retry the game.

If that’s not the case, or if issues persist, we’ll want to see some system details.

Obtaining System Files

You can include the DXDIAG in a reply to the forum post. Place it between rows of ticks (`) for formatting:

```
Like this.
```


#5

Good evening

My computer system details is in Chinese so I hope it’s still understandable. No am not using any Razer Software on my system. The website isnt letting me upload any files or submit tickets to support so am unsure on what am sure to do now.

Its getting annoying because after i rename the variables file the game will run but when i click on it. The screen goes black


#6

Did you set the height and width to the panel native resolution?

Made sure your laptop is in high power mode when trying to run the game? HotS is very resource intensive and energy saving might cause compatibility problems. Even when plugged in, the system might not be running in a performance orientated profile.

As a temporary test I would suggest disabling your Intel integrated graphics to see if that helps incase it is trying to run from the wrong GPU. Since you are using a laptop if this does work this is not a good permanent solution as the integrated graphics are needed for good battery life.

When your hard drive was repaired I assume they reinstalled the OS? It is possible a vendor specific piece of software was not installed which is required for correct functioning of the system. Check the vendors website for software downloads and anything related to power management, overclocking, performance enhancing, etc might need to be installed for the system to function correctly. Laptops are especially tricky with regard to this as they often use OEM specific boards and such hardware which will not operate correctly with the default generic drivers intended for consumer branded products.


#7

can also use

[code]
Text goes here
[/code]