Attack UI, sprays, and AOE indicators not showing on M1 Macs

This has been a problem for ~6 months and still no real response for the developers. Still can’t see the attack overlays for aiming, sprays, or AOE indicators like bombs like D.Va’s self destruct. This makes the game extremely difficult for new players. If you are on an M1 Mac, go to a map that has no floor on the edges, The layer is still there, just hidden on normal map terrain.

Please Developers! Fix this!


So frustrating that this is STILL not fixed. I got excited when I saw the new patch today, and crushingly disappointed when I ran it to find the same bugs still there.

It’s doubly frustrating because HoTS runs so damn well on the new Macs, except for this one stupid bug!


I guess the solution is to turn on autocast :confused:

1 Like

Same problem here. Hoping Blizzard will acknowledge awareness of this at least.

Autocast is a weak at best workaround. Sometimes you need/want to see the aoe on your spells. And you definitely want to see aoe from allies, opponents, and bosses.

I doubt Blizzard will fix it soon, the bug was there last year (see another thread). Maybe I will just carry PC back to office when playing games…


Same problem here! Any fix yet?