All play modes bugged

Even after restarting, all play modes - except ARAM - are non-clickable, i.e. greyed out. When trying to get into ARAM “There was a temporary problem with your request” In essence, NONE of the play modes work at all. Please fix and report.

slt, même problèmes pour moi depuis aujourd’hui midi

Hello.
Same problem here.

My region is Europe.
But if I change region to Asia or Americas, I can play as usual.
It is just Europe (on which I have been playing) which will not show any of my champions, loot or collections…

Meanwhile, my friend can play on Europe as usual using the same internet connection.

Even tried uninstalling and reinstalling the game - Still same issue.

Same issue, same region.

Hello.

Just to add, even deleting cache folder, uninstalling Battle.net and reinstalling Battle.net did not solve the issue.
Appears that meanwhile, I will just play on another region.

Same for me here but when i change account everything seems ok. Is it some account corruption ?

Update: Mine Battle.net just got updated.
Now, Europe region is playable for me. :raised_hands:

On a side note, Europe appears to be the best region for AI, Quick Match and ARAM - I usually get games throughout the day with a wait time of around 1 minute.
Today, tried Americas and Asia.

  • Next to no game on America.
  • Quite long wait time on Asia.

Yep it’s ok for me too.