Uninteractable Menu, only friends and settings work

When logging in to Hearthstone, I am getting stuck on uninteractible main menu, “Hearthstone” button is greyed our, “Battlegrounds” and “Mercenaries” are looking normally but neither them, nor Collection or pack opening is interactible. Only buttons that work are friends menu and settings


i don’t know why they think this game being completely broken is a good look when also asking for like hundreds a year from people

same here everything bug after a bit and i can only use friend and setting and have to restart the game cant open pack or use collection

Same here, 4 days and its still not fixed… I tried checking if different accounts have the issue too but to my suprise they dont… At least i can log in and play on phone but still its a joke that issue like this isnt fixed yet.

I found out that this only affects me on PC on Europe. On my android phone on Europe it works, on America server on PC it works well. But still, no response from support for 5 days. I’ve reinstalled the game, reinstalled the client and nothing helps

Exact same issue. It happened after reloading my game to enter my fireside gathering. I was playing before the window opened and reloaded about an hour into the time window.

Same thing happening to me. I can play on the European server but not my main Americas server. The last thing I did was purchase the bundle from the shop.

Has anyone come up with a solution for this issue?

  1. Press Windows Key + R
  2. Type in %localappdata% and press enter
  3. Go into the Blizzard folder
  4. Go into the Hearthstone folder
  5. Find the Cache folder here and delete it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.