The Dalaran Heist - Bugged Menu


#21

Good afternoon,

We’ve deployed a fix that should resolve the issue that prevents some players from starting a Heist run. Please let us know if you continue to encounter this problem or related issues and I’ll investigate further.


#22

The issue is still persisting in my client. I fully logged out from the client, restarted it, and logged back in. My game still has the exact same issue of being stuck on the Challenge 1/8 screen with no hero portrait and a bugged start button.


#23

Can you try the additional step of starting a Rumble Run (Rastakan’s Rumble) or Monster Hunt (The Witchwood) then Concede and logout and restart.


#24

Monster Hunt did nothing and my Rumble Run crashes the game on clicking to enter the mode.


#25

Hi, logged off everything and tried it again but it’s still not working for me


#26

Thank you for the updates. We’ve confirmed that this has fixed the issue for some players, and are working on an additional fix to resolve the remaining issues. Thank you again for your patience.


#27

I am unable to play but for a different reason, I’m stuck on boss 2/8 of heroic and I can start matches but it puts me in a dalaran bank run on normal mode instead of heroic. I can fight bosses but get no passive, no treasures an can’t pick cards.


#28

Purchased dalaran heist, have not been able to play it since. Each attempt brings me to the first challenge of the first chapter, play button does not function - it can be clicked once and then freezes.

I have reinstalled within the last hour. All other content seems to work.


#29

My hero is still missing and still cannot play the run.


#30

Yeah for about a week I’ve been unable to play due to the play button not working.
Tried loging to IOS to see if that worked and nada. Whens this fix coming?


#31

still have the same problem hope it fixed soon.


#32

Having a similar issue. I can play heroic with no problem but in standard, when I press PLAY the button does nothing.


#33

i have the same problem. the latest fix did not fix the problem.


#34

Hello. I have this bug since day 1 of the heist. Please fix as soon as possible. I am still stuck at the boss screen and my hero portrait is missing. I made a reddit post earlier and they said to report it here.


#35

Please fix this issue or return my money…


#36

Same bug here, but only in normal mode. Heroic mode works fine. Please fix or return my money! On both IOS and destop version.


#37

Still can’t play normal mode. Stuck at the screen with the play button and my deck on the right side and challenge 1/8. My hero portrait is blank and i can click the play button once (nothing happens) and after that it freezes and won’t work. It’s been like a week that I’m stuck playing heroic only pls have mercy and fix this. On both windows and android. I can only lose to Kizi Copperclip in round 1 so many times :frowning:


#38

I have the same issue, hero portrait is blank and cant play the adventure at all, please fix soon


#39

Similar issue here, cant hit play, leave and come back to the same screen, this is on pc


#40

Still having the same issue on normal mode as well.