Still Getting Unity Player Error Post Patch

Hello,

Prior to the patch often when playing the game, it would disconnect, reconnect, then crash. I was hoping the patch would fix it, but it seems it is still an issue. This is the error I get. Does anyone know how to fix it? Thank you!

Faulting application name: Hearthstone.exe, version: 21.6.1.58961, time stamp: 0x602ddfee
Faulting module name: UnityPlayer.dll, version: 2019.4.21.28076, time stamp: 0x602de147
Exception code: 0xc0000005
Fault offset: 0x0099464f
Faulting process id: 0x2984
Faulting application start time: 0x01d7d11016b9e814
Faulting application path: C:\Program Files (x86)\Hearthstone\Hearthstone.exe
Faulting module path: C:\Program Files (x86)\Hearthstone\UnityPlayer.dll
Report Id: 1417dcc3-23b3-43b7-9f8c-1f82f85ad67f
Faulting package full name:
Faulting package-relative application ID:

Hey there,

Let’s go ahead and have you post a ‘DxDiag’ so we can further investigate the problem. Here are the instructions:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Once you have that made, open the file. You’ll need to copy and paste the contents of the Text document into the post, and put four Tilde (~) marks above the DXDiag. It’ll look like this:
DXDiag goes here

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

Thank you for the help, and here is the DxDiag output. I am using pastebin because the output is too long and contains a disallowed number string under WER9.

Thank you again!

Hey RainbowJack,

Thank you for taking the time to post that DxDiag report! My apologies for the delay in response. I’ve reviewed the DxDiag, though I did not see any overarching issues that should be causing the UnityPlayer to crash. With that in mind, let’s try a few troubleshooting steps to help isolate the issue:

  1. If you have any third-party deck building or deck tracking software installed, try temporarily uninstalling it to ensure that it isn’t causing the issue.
  2. Run a Scan and Repair on your Hearthstone installation to ensure none of your game files are corrupt and to allow the installer to resolve any issues.
  3. Reinstall Hearthstone to ensure you have a fresh set of game files.

If those steps yield no results, try closing any potentially conflicting programs/applications by disabling startup items with the steps below. Before trying the steps below, please close unnecessary programs and restart your computer:

  1. Press Ctrl+Shift+Esc to open the Task Manager.
  2. Click More Details in the bottom-left.
  3. Select the Startup tab.
  4. Right-click on each item listed and select Disable. Make sure all are “Disabled”.
  5. Restart the computer.

If the issue is resolved after restarting your system, you can enable each startup application one at a time to determine which one is causing the problem. You will need to restart between each application you enable.

Note: To re-enable startup applications, follow steps 1-4 and select Enable.

Hopefully these steps help get Hearthstone back to running stable on your machine. Let us know how it goes!

I tried many of these solutions to no avail, but after the recent patches, I have not dropped any games, so something in there must’ve fixed it :smiley: Woo hoo!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.