[Jul 2] Stuck on Tavern Doors or Playful Sprites on iOS/Android


#177

Won’t even complete install now. Freezes at the end.


Times out and won’t load
#178

Hearthstone version 14.6.32097

Have you reinstalled the app?
Yes, 3 times thorugh Google Play.

When was the last time the device was restarted?
Today, after last reinstall.

Do you see a Blizzard sign
Yes.
Do you see tavern doors?
Yes.
Do you see any version check or download bar?
When reinstalling i do. When trying to start the game when already installed- no.
Does the stone circle logo pulse?
No.
Does the Hearthstone logo appear?
No.

Last, what type of device you are on?
Mobile device: android version: 6.0.1


#179

Playing on adroid v. 6.0.1. It worked yesterday until the afternoon. Get to the tavern doors with no pulsing, then eventually i get a system message saying hearthsone has stopped.


#180

I am unable to tell which version of Hearthstone i have as the game will not fully install.
I have reinstalled several times.
When opening i see the Blizzard logo then the tavern doors and then the game not responding message.
My phone is a Galaxy J3 Luna Pro running android OS version 6.0.1.


#181

Oh wait. I saw the how to check version thing. It’s Hearthstone 14.6.32097.


#182

ANDROID VERSION USER SIDE TEMPORARY FIX:

EDIT: more research and testing done. Some steps listed below may not be necessary. See (Revised steps) section for changes. Original steps are marked as (Original steps).

(Worked for me for a few days, then issue began again. Repeated steps again and it didn’t work the first several times, and then eventually did. This may not work for you.)

Short version steps to follow:

(Revised steps): It seems that there are only a couple steps you need to follow, and the rest may be unnecessary.

1: Delete all patches by clearing all data and cache for HS. (Also disable notifications for HS before opening HS)
2: open HS and wait for update to finish.
3: update may near finishing or finish and then Hs will freeze. Exit HS and close application, and open again.
4: HS will open regularly, and ask you to sign in. DO NOT sign in. Stay at opening screen while assets download. Assets must finish before signing in.
5: after assets download, log in. Game should now run properly.

It appears that this only fixes the issue this first time you open it, and after that, the game breaks again and you must follow these same steps again. Works multiple times, I’ve got HS to work for the 3rd time since July 1st patch following this method.

(Original Steps):
(This is how I got it to run the first time. Second and third time I used above steps, so some of these steps may be unnecessary).

Clear cache, clear data for HS. Uninstall. Reinstall. BEFORE opening HS, go into your app settings and block notifications from HS, and I suggest every other app as well, or at least ones you get notification from often. BEFORE opening HS, clear ALL notification from your scrollbar, at the top of your phone.
Open HS and get update, keep HS open for entire update, and during asset download in the HS settings in app.
Any notification may cause HS to crash.
If, after update is downloaded, game freezes on or near 0b downloaded, close app. Then, when opening again, it should progress to log in. DO NOT LOG IN YET, wait for asset download to 100% be complete. For me, clicking log in before asset download was finished caused the game to freeze, and I had to restart the steps from the begining.

More detail:

I finally found a series of tricks to get hs to run on mobile.
After lots of experimentation, and deep research on the issues other people were having, I have concluded that at least one of the issues is notifications in the scrollbar of your phone. Any notification will make HS crash, INCLUDING the notification which shows the status of the update. To install the game and make it run, you have to clear all notifications, and then go into hs settings and prevent hs from showing notifications. Otherwise, HS will always give a notification that update is complete/ downloading, because it always checks the status of the newest update before it is installed. So, the update notification itself, which is always present before update install, always pops up before update is installed, which always crashes itself.

It would also be a smart idea to disable app notification from every app on your phone, as it seems any notification in the scrollbar causes HS to disconnect or crash.

This fixed the game FOR ME, and I cannot guarantee it will fix it for you. This is on android, I know others are having same issue on IOS and I cannot confirm that will help for IOS.

I pray Blizzard properly fixes this issue soon. Also if this fixes game for you, I humbly request you nominate me for the Nobel Prize for amount of work and research I’ve done on this issue.

If these steps work for you, and in your ultimate generosity would like to gift me packs or bundle, my main HS battletag is:
Dubstep420#11902
The account I am posting from is my alt that I used to grind the murloc shaman hero.


#183

4 days, I’m losing in game money to buy packs… I think for every quest we lose you have to compensate us with a free pack… It’s not about rights it’s about you as a good company.


#184

Doesn’t work for me but thanks


#185

Thanks, UrMum. This is the closest thing to a solution I’ve gotten so far.

I tried reinstalling with all the notifications turned off. I also set my screen saver to 10min of inactivity (my phone doesn’t allow me to turn it fully off).

After installation the doors opened, the hearthstone logo appeared and the asset download began.

After it was finished I proceeded to answer innkeeper’s query of whether I’m a new or an old player.

Instant crash.

But at least some progress was made.


#186

By the way, this is post no. 179.

When this thread hits 500, we all get a golden hero.

Which we obviously cannot use.


#187

I also tried the above. blocked/cleared notifications, ,cleared cashe. this was enough to get me in the game, it downloaded all of the assets, i stepped away to do stuff, the game timedout eventully, and i havent been able to get past the door screen since. I was thinking about getting a new phone anyway, but does this have anything to do with the hardware?


#188

As I was reading this thread, I noticed that after the 14.6.32097 patch the issue seems to affect only Android devices version 6.0.1 or earlier.

I would like to hear if the problem still persists with iOs or post-Marshmallow Android devices.


#189

Yes, follow steps again but this time, do not do anything until asset download is complete. Don’t log in or do anything. Keep app open but don’t do anything until it’s done.


#190

Also, the Android version bit is not accurate. I have newest Android version and still effects me. And yes, this bug is effecting IOS and tablets as well.


#191

DO NOT buy a new phone just for Hs, as this bug is affecting new phones as well. Of course if you were going to buy one already go ahead, but HS may still not run on your device anyway, Android or IOS. Even PC right now is unstable, yet still largely more stable then mobile client.


#192

Blizzard… Blizzard Blizzard Blizzard


#193

PC is fine and stable. Only mobile is out of commission atm.


#194

I don’t know about a Nobel Peace prize, but some kind of badge for UrMum69Gotem is ok (lol what kind of handle is that); his post definitely looks like it stumbled on the issue for older Androids: seems to be a notification issue. I disabled every single App’s notification (although just the Amazon App store and Hearthstone app should be enough, one would think). I was finally able to get old 5.1.1 Android on Nexus 10 to load HS (latest patch as of this post). Of course, thanks to Blizzard, I lost out on 10% coin back offer.


#195

Same problem here, Huawei honor 7. I tried turning off/on the app and phone. Also tried re-installing the game few times, still doesn’t work. Obiviously there is a problem with the new update. Please fix this soon as possible. Its been a week already.


#196

Same problem, Xiaomi Redmi 4, I tried reinstalling and clearing cache several times but still doesn’t work. I will try disabling notifications trick but I am already so annoyed of this…