Hearthstone stuck loading


#1

everytime i load up hearthstone it gets stuck on the tavern door loading screen with the flashing hearthstone logo.

And this is what comes up in the logs:

— End of inner exception stack trace —
at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in :0
at bgs.SslSocket.OnAuthenticateAsClient(IAsyncResult ar)
------------------------------- (Void LogError(System.String, System.String) at :0)
E 21:02:51.6878395 [Main] Unhandled Aurora State (Void LogError(System.String, System.String) at :0)
E 21:02:51.6967452 [Network] Network.OnFatalBnetError() - error=[event=Bnet_OnConnected error=3004 ERROR_RPC_PEER_UNAVAILABLE] (Void LogError(System.String, System.String) at :0)
E 21:02:56.5593347 [SslSocket] Exception while ending client authentication. System.IO.IOException: The authentication or decryption has failed. —> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server.
at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000] in :0
at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.ProcessAsTls1 () [0x00000] in :0
at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Process () [0x00000] in :0
at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHandshakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000] in :0
at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] in :0

I’ve tried re-installing battle net and HS
I’ve tried changing the fire wall settings
I’ve used my friends account and that doesnt work
My phone works fine on my account but when i log onto my pc it gets stuck on the loading screen. please help.

Best regards
(I was told to repost here)

cdn .discordapp.com/attachments/380055863223648266/577827626815586304/SystemFile.txt There are my sytem files
cdn .discordapp.com/attachments/380055863223648266/577827611686731787/DxDiag.txt and here is my DxDiag File
(i cant post links and sorry if it not being in english is a problem.)


#2

I’m having the same issue on my samsung S10e, stuck at loading screen forever, tried to clear cache and game data, didnt solve the problem. the game works fine on my PC thou.
blizzard, pls look into this issue