Hearthstone: Restart required after every game

Whenever I finish a game in battlegrounds or ranked i get the message: “disconnected, game completed and recorded! restart hearthstone to continue”

I’ve experienced this since around january 2020.
I used to run decktracker while playing, but recently reformatted my computer in an attempt fix the issue.
I’m currently playing on a fresh reformatted pc where ONLY Hearthstone and battlenet is running.
The lease time on my router is set to 24 hours, and it does not matter if i use WIFI, cable or hotspot from phone.
Ive tried restarting router countless times to no use.
I have not experienced any kind of connection issues in other games such as CS:GO or Dota 2.
During actual hearthstone games there are no lag or any issues, it just requires a restart every single time.


Hey, Probusk! Does this happen on a different account by chance? Have you tried a different region? I am curious if possible location might possibly make a difference, have you tried a VPN to a different country to see if the same thing happens?

Usually, this error is a connectivity related error, but given the steps you’ve tried, I want to see if we can narrow this down any further.

Same here, EU server. Except it doesn’t happen every game, just quite often.
Has been like this for weeks, maybe months.

I have been having this problem for the past couple of hours, same message as above… a restart is required after each game I play. I am on the US/Americas server

1 Like


This is now happening to me also, after “almost” every game since the patch today. I’ve never had this problem before, I’m on MacOS Catalina. I’ve restarted the launcher, and the computer itself. I noticed I also have to “go online” in battle.net after this happens, so I am getting dropped from the battle.net service at some point during the game. I have no other connectivity issues in my house, with multiple computers, etc. I’ll do some more testing, Region/OS, different machine, etc and see if I can pinpoint a commonality.

Having the same issue all day today. Really wanted to play duels. :frowning: Hopefully someone can figure out a fix for this.

Having exactly the same issue for 2 days now. Americas server. I tried with another account, and it’s the same.

I am using a Mac, btw. My WiFi and internet connection is stable.

Same here… Kicks me out after a game then has a hard time getting back in sometimes. Feel like its a connection issue but everything else works. Even checked my pc then reformatted also and still same thing.

I’m just going to stop playing hearthstone today because of the multiple screens and log-in credentials I had to go through today to let you know of a simple problem that you’re probably aware of. Perhaps you already track error codes in your system already, but personally I think hearing from a client is more important than predetermined error codes whether or not they have the patience to go through 4-5 webpages and multiple barriers to report it. PLUS I can’t even submit my draft to my original problem because the website isn’t intuitive enough to display the draft forum post I created that I thought I had already posted. What’s up with that, sorry for hating; but I thought it would be a pleasant experience after purchasing hundreds of dollars of packs as well as being a long time subscriber to WoW.

1 Like

My own father would have handled this situation better and he isn’t a multibillion dollar corporation in his business.

Similar problem on iPad pro, disconnecting and reconnecting during games. Forcing me to log in from original credentials after some disconnections. All other internet activities are normal.

I posted 4d ago, and this morning I have noticed a slight improvement in that I am not disconnecting after “every” game. I am still getting knocked off, sometimes immediately after a match I am asked to reconnect or I get a message stating I’m not online basically. This requires me to exit the game and “reconnect” on the battle.net launcher…
This problem seems to correlate with your last patch, I never had problems prior to that patch, and directly after the patch, this problem started.

If I get some time, I’ll TCPdump and see if I’m getting RST from your end. Changing regions didn’t make a difference.

Ive tested on the european and american regions. The issue is for both regions. I’ve also tested with VPN, and that also does not solve the issue.

Hey all,

I noticed a number of similar reports recently. Could we get the following information for tracking? This is:

  • Operating System
  • Router Model
  • Modem Model


This is happening to me right now (11/12)

I’m having this problem too. It’s irritating and frustrating. Is there any reply from Blizzard yet?

I don’t have a connection issue. Every other online thing works fine. Do you have any solution? Quitting after every game ain’t fun. It’s frustrating and irritating. Help us

1 Like

#windows 10


other things are working fine.

same problems for the past 9 days or so, and already have an open ticket, but posting here too:

Mac OS 10.14 - Mojave
eero mesh router
Netgear CM700 (puma6) ;(

Yeah same issue here, American server, started happening roughly when this forum was first started. would love for it to be fixed for the upcoming expansion!
OS: Windows 10
Using a Linksys router that’s a few years old, not too sure about model number.