Can't start a Dalaran Heist run


#162

Any kind of update would be nice. If you’re having trouble getting a fix done, at least let us know?


#163

Same problem here, can’t launch heroics get stuck on black screen.
Windows 10/pc


#164

I really hope this gets fixed eventually, I paid $20 and haven’t been able to play it once. it either needs to get fixed or we should be able to request refunds somewhere because this is ridiculous. It’s not like it’s some small game company releasing their first game.


#165

eventually the gonna fix it hopefull its this year


#166

Same thing happened with my Heroic Heist run… Disconnected when I was playing on my Android now I can play on Heroic at all on PC or Android. Disappointing after buying the new expansion and being excited to play…


#167

I agree actually. I gave them my money they gave me a broken product.


#168

@blizzard can you have maybe some respect for you player base en do something and react :wink:


#169

exactly the same problem i have. did u solve it already?


#170

@chockoladnica no of course they not car the sayd 2 days ago they known they issue after that its completely silence


#171

Still nothing? Maybe I should just open a Paypal dispute or something… After paying 20 Euro for the adventure I at least expect some communication.


#172

yeaah just do that for real this is ridiiclilous i am no in chat with blizzard i wil update what they say afterward


#173

As promised the answer from the support chat so lets hope this is gonna happe

“Thanks for waiting, yeah just checked the report from our developers, it seems that later today we might actually have that fixed once our US Office starts working (it’s still 4am over there).”


#174

OMG! Myself just starting the Boomsday challenge and it fixed problem with Dalaran Heist crash…

Upd: Dalaran heist run works like hell


#175

Well I have the same problem
Hope Blizzard fix it soon, is there any current fix for this situation?


#176

jezus…its been a week… about a product I PAID. and i still cant play it.
For the love of god blizzard , you better give us something…


#177

A fix for me was starting boomsday challenge, completing some and then going back to the bugged run. The run itself didn’t start, instead I went into another Boomsday run, left that, got the victory screen for Dalaran Heist and then could start a new run. Kinda weird, but it works.

Windows 10-64bit


#178

Edit:

Never mind this just loaded the next Boomsday Puzzle from the Dalaran Heist option


#179

Funny how closed beta, had no such problems (correct me if I’m wrong, but I really don’t remember having any issues with the game, other than maybe rare disconnects). And now, after so many years, how can you even ruin it this way? Is this expansion launch so different from the previous ones? Or moneygrab in our days not enough to release quality products?

I miss good old blizzard :cry:


#180

When I couldn’t play heroic Heist I tried having some fun in the dr. boom/ boomsday expansion. When i tried to play the heroic heist again I ended up in a dr boom puzzle. It seems that heroic heist doesn’t know what files it should read and just enters the battlefield where you last game was played. Some players have experienced that it takes you back to a normal heist if you just played it because of this. This also explains why you can’t play the other similar adventures such as dungeon run and rumble run. My guess would be that the adventure run algorythm has been changed such as it can’t properly read the right files. Don’t know if this helps but please fix this soon.


#181

I’d guess the same, and yet it’s stunning how lazy or unskilled one have to be to not be able to fix it on a WHOLE WEEK. 5x8h of work was not enough? Damn, that’s amazing.