Can't start a Dalaran Heist run


Any updates on this? I was really hoping to be able to play this :’(

Regretting my purchase pretty hard rn


Day 5 since launch and I’ve had the glitch since day 1… heavily regretting giving $20 for the full adventure when I can’t even play what I paid for


Ran into the same issue on Heroic on Android.

Selecred hero and deck then backed out to title screen. Once i went back in i was stuck on Challenge 1/0.


Blizzard dont care abou this they only care about get money
and bugs like buble from bartende bob because yeah so importtant -_-


@blizzard fix this now finnaly !!! for once do your job


I just got a quest to beat 3 heist bosses. Way to rub salt in the wound.

All i want is to enjoy the adventure i paid money for. Can we get some kind of compensation?


I cant play wendy boss the play botton is frozen since friday, can help?


4 days now, where can i get a refund i payed irl money for this. another great example of blizzard being amazing in their communication


I have same problem but with Marie Loom


Having the same issue on android and pc.
Beat chapter one on first run, played 2nd run with new deck and lost, 3rd run stuck on loading the first boss, press play and nothing happens.


I have same problem. Dont copy xddddd


Getting the same issue, both on heroic and normal. On IOS, Mac, and Windows 10. I tried to fix it by starting a Witchwood adventure game, worked fine, and when I tried Dalaran Heist again the background that is usually black was the one from Witchwood. Weird.

EDIT: I started a couple of Boomsday challenge games, and it began working. Said 1/8 instead of 1/0. Although the background was still black.

EDIT 2: Thought it was fixed, turns out it actually just put me back in the boomsday game… Weird… Here’s a screenshot of one of the boomsday bosses appearing in Dalaran Heist. Hero power is even ‘Heal to full to survive this hero power!’ or whatever.


Yea exactly, finally someon i can relate to!
Your heroic run is overwiritten with the Boomsday adventure.
I have the same issue only mine is overwritten withe the standart Dalaran run. I would fight against Bob with real Mana instead of coins.
ht tp://

Removing the blank between ht tp should work


Yup, lol. Mine looks like this and just takes me straight to a Boomsday challenge as if I’ve selected it in the first place.
Got so excited thinking I could finally play, but saw the puzzle piece and let out a sigh of disappointment, lol.


The last com from Blizzard was 2 days ago and still no fix.

I want a refund on my money.


Relax. Just don’t paste any urls or they will temporarily ban you for… pasting that xD This thing is not working on PC, IOS, ANDROID and they soap ppl eyes with “give us the platrorms it does not work” xD It’s almost a week and those morons have still no clue? Let me just announce You the 1st world solving problem attitude: let them wait, cause i need my 4th breakfast break, even while i am the responsible for this! xD GJ Blizzard!


Day 5 and no fix. 2 full days since last communication about this issue.
Guess Blizzard really doesn’t give a damn about their players. Disgusting.


Since you’ve shut down our ability to contact you and have given us no information on an upcoming fix, I’ve shared this issue with a friend at a gaming news outlet. Expect an article in the next few hours.


So did Blizzard firing so many employees gut the QA team? How did this significant bug that makes the mode unplayable slip past them even?

For my part I didnt do anything particularly edge case to trigger it. I bought the second wing with gold, played through once to unlock a hunter hero, and then tried to play the first wing with the new hunter. Bam, broken.

Astounded 5 days of unplayable new release from Blizzard. Guess this is where the company is going now…


I’m able to press the play button once but then it does nothing, my hero is gone and if I leave and comeback its still the same, the normal difficulty works fine but heroic doesn’t.
Already tried reinstalling the game but it doesn’t work.
Yesterday I was told to way a few hours for it to be fixed and nothing after a whole day.