Can't start a Dalaran Heist run


#182

CONFIRMED WORKAROUND:

Start a boomsday puzzle run, do a puzzle or two then leave (concede).

Start your bugged Dalaran heist… it will load the next puzzle of your boomsday run.

Concede this puzzle, and it will reset your heist, enabling you to play again!


#183

I started a heist run and then had to leave.
It auto disconnected me after some time.
Whenever I try to press play, nothing happens but I’m allowed to press leave.
There is no hero portrait where the candle is.


#184

boomsday workaround didnt work for me. after doing a couple puzzles I went back to the bugged run, it said 1/8 this time instead of 1/0 but hitting play wouldnt start a match. hitting play did nothing.

I will say a couple days ago I tried starting a boomsday run and then going back to dalaran heist, at that point it started another boomsday run. But after playing it it just went back to being bugged. Now it doesnt start the boomsday run for me at all in dalaran heist mode.


#185

Thanks a lot! This made the trick


#186

Didn’t work for me, is there a specific puzzle you use/used?


#187

Thank you much!! :pray:


#188

Does not work for me. After I concede with puzzle as “bugged dalarian heist”, then I get… another Puzzle, when I try to do Dalarian.
Note: it would not allow me to play this adventure “again”, it’d be “the first time”…


#189

This worked for me, but only for Normal mode. Heroic mode still isn’t working for me for some reason.

EDIT: Nevermind, it didn’t actually let me play and has gone back to the black screen thing.


#190

I cant start heroic runs still on 1/8 when I click Play it does the press animation but doesn’t start or do anything else, I’m on iOS mobile and it was working fine the first few days.


#191

It still doesn’t work for me :frowning: On Thursday evening, I paid for an adventure game, but I can’t use it today! I feel cheated and robbed …


#192

I just picked q random one from The boomsday project, then went to concede. Went back to the heist one, and it asked me to continue with the boomsday, so I did, then concede again


#193

still nothing @!blizzard time for a good article for a wel known gaming new website someone a suggestion


#194

We’re two days into the work week, guys. I can understand slower communicate on weekends but this total radio silence is getting absurd. At least post some kind of update. If you’re having a hard time getting a fix made, then tell us! People who dropped real money on something that doesn’t work deserve an update at least!


#195

It’s a miracle! We have an update!

Taken from a request for refund:

Monday is the magic day, folks. I’ll start polishing my pitchfork.


#196

Wait… The bug is fixed? I still can’t play normal mode…


#197

Not working for me either


#198

Fuc king blizzard clowns is aleardy a week and you cant fix this fu cking bug,bunch of specialist IT with same classes as a train


#199

this issue also occured the first time for me. Played the first wing a few times on my Android without problems. Tried to start it on my senior W7 PC … got the error over and over again.
Didn´t buy other wings yet (or will ever Blizz)


#200

Heroic not working for me. But now, after trying the “workaround” I’m stuck in a loop, playing first round of a run. If I win and try to load next round it just restarts the first one. If I concede same thing: first boss again.

But hey! on a bright side, its different first bosses! Cool right?!..


#201

Ok, guys. For me it worked (restarting Battle-net, not only HS), but it was NOT fixed on Monday, as I started my PC today’s morning and had to start up HS as well and it was NOT working. I managed to face 1st boss of new adventure just now. Now I’m also able to face 2nd one, so… for now, Normal mode works for me.

(did not have to approve/install anything, so it looks like server issue)