Cant play mercenaries

After the latest patch for android, mercenaries mode is simply returning me to the main screen and doesnt open.


here i have the same issue


I have the same problem

Same here, nothing works to fix it, downloaded all patches, deinstalled and installed again, changed in game the settings, the language…clicking on merceneries just gives you an error massage of a failure loading the menu and you remain in the main menu…although, on patch day, before the fix patch, it worked somerimes, but crashed after each merc fight…

Can’t load mercs shop in game. I have 19000 gold and I want to buy mercs packs. The shop website only sells the 2.99 and up pack bundles and I don’t want to spend cash. I can’t even do any of the rattlegore tasks either as the game crashes whenever I try to enter a bounty too. Mercs was actually my favorite mode so this is so frustrating. I only have mobile, no PC so I can’t just try it on desktop. Please fix this mode so I can have fun again.

From what I could understand:

1- It works on another accounti played a fresh account and it worked perfectly.

2- It bugged the merc packs first time I tried to open them, the game softlocked.

The game is still not fixed in the last patch 25.0

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.