21.8 Known Issues

Hi, a few bugs/unintended interactions I’ve had in mercenaries since 21.8:

  1. Choosing Cookie Task 6 on mysterious stranger event with the story-line quest and 4 other tasks active (i.e. 1 slot remaining) led to campsite full message and coin handout for the merc.

  2. Cookie’s Go Fish! tokens don’t self-destruct even when all opposing characters are defeated.

  3. Mutanus Task 2 (Block 30 damage using Scaly Taunt) can be completed by battling an opposing team with the merc in PvE or PvP.

  4. Disconnecting during PvE leads to loss of progress sometimes (at least 4-5 instances).

I don’t mind achievements on limited time heroes. I do mind when achievement can’t be completed when that hero is available.
I hope they will fix it soon. We are almost out of time.

Stay safe guys.

1 Like

Yea! your fixing the bug with Talented Arcanist and Cram Session! Thanks

1 Like

After the latest patch my fully upgraded campfire in Mercanaries only holds 5 travelers now instead of the 6 prior to the update. Aggravating when I think I have an open slot to add a traveler using the Mystery Boon/Coin in the bounties.

Anyone else seeing or having this issue?

So to better Clarify, say I put a Minion (with Body Wrappers Effect) in my Deck with Shudderwocks Effect.
Since Shudderwock should be the highest Cost Minion currently being played, would the lower Cost Minion in the Deck affect the Battlecry?
Or is there simply no way to make it work with Shudderwock and the “Repeat Battlecry” Effect?

The max for ones you can farm has always been 4. The other two have always been special slots that are reserved for the daily task and the story task. No change was made here–you probably just finished the story tasks.

Yes, you should be able to play Drek’Thar–likely not get anything, because you run Shudderwock and other things that cost more than 4–and then play Shudderwock and pull something based on Shudderwock’s mana cost.

Hey, i dont know if I am right here but I got a bug that I cant fix or find somewhere.
Its in Battlegrounds.
Every time I start a game and it comes to choosing your hero. The time counter gets stuck by 00, and nothing happens. The game wont begin. When I close the game and restart it, I get the notification that my game gets resumed, but than gets stuck in that loading screen. I am losing my rank points, so please help!

Known and being worked on right now.

1 Like

Is the (new) issue with the Dragonblood passive in Duels already on the list?

I saw a few posts on it but they didn’t have blue responses, so I’ll summarize just in case: the good news is that it no longer targets spells, but the bad news is that it doesn’t target minions either and is never triggering at all.

1 Like

I noticed this yesterday (11/18) while playing the tavern brawl, Battle of Tol Barad, and again today inside of normal/casual hearthstone.

Playing on Android, my app auto-updates and had an update when I logged in today. I am not able to get past the tavern doors (disrupted whilst linking to Blizzard services). Concerned this may be the ‘voluntary update’. Can’t roll back the update. What should I do to resolve?

Edit: performed full reinstall, as this resolved the previous Fractured update issue (play store not having the correct update), but am still stuck on the tavern doors loading screen.

I have the same Problem. Reinstal didn’t work yet. Since the auto-update i can not get passed the tavern doors.

Then there’s another bug im my opinion in the stormwind’s achivementsystem for warrior.
In all acvievements with 3 steps you get 100 XP for the first 2 steps and 500 XP for the last.
In warriors achievement in which u have to attack with pirates u only get 200 XP when u finish the third step.

1 Like

Still no fix for the Android problem?

Reinstall didn’t work. The app auto updated during the night…
Would be nice to know if there will be a fix (rollback) anytime soon.


Same issue here, unable to connect after auto update. :+1:

1 Like

Yeah, totally misunderstood the Card :flushed:
Anyway thanks for clearing that up!

1 Like

I cannot play as my game auto updated.
My only day off to play and now this.

1 Like

The issue was fixed some hours ago, so you should be good now if you didn’t already notice. You just need to update once more.

1 Like

Confirmed again as of 11/20. Received credit for “Warlock Duelist” instead of “Diablo Duelist”. I’ve heard of others getting credit for “Warrior Duelist”.

The same the game not connect