Why cant I post in console discussion?

Not related to the game but i cant post anything in my the console discussion. My psn is linked to my account, and still I cant even click on the button to make a post, anyone know why?

Did you get it to work? I have same issue. I found this:

Yes i did thanks though. I cleared my cache like they said and it still didn’t work so I emailed support, and they did a hard reset on my account or something. Then they told me to clear my cache again and it worked.

Thanks for the reply. I tried clearing cache now. Still doesn’t work. I will investigate further. Thanks again!

Cannot post there still despite owning the console edition of Diablo 4

Same problem here. PS5 Account is linked correct and I have 100+ hours in D4. But I can’t post in console forum.

Got the same problem when D2R was released. Even support couldn’t help me. A few weeks later it worked suddenly.

Any Tipps?

Having same problem lots hours in everything verified 100% yet can’t seem to post on this FORUM unless it’s in limited places like this post!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.