Text language bug - English or other languages cannot be selected

Hello.
I premise that I play Diablo IV in Italian and until last night I had no problems.

It has been since this morning that the game starts up for me written all in Spanish.

In the game’s internal settings, I have Italian as the voice language, but only Spanish and Korean are selectable as the text language.

In the Diablo settings on the Battlenet client, Italian is correctly entered as the language of texts and voices.

I tried the following things before asking for help here:
1 - Restarting the pc.
2 - Restart battlenet.
3 - Uninstall and reinstall Diablo IV.
4 - Select the English language from the client and then put Italian back in.
5 - Select from the battlenet client the English language and then enter the game, nothing changed except that in the internal settings it was now possible to also select English in the voice languages. But for the text languages, only Spanish and Korean remained selectable.
6 - Enter Diablo IV and reset the settings to the default settings.
7 - Use the analyze and repair function of the game from battlenet.

None of this helped.
Whenever I enter the game, it is all in Spanish and I can only choose between Korean and Spanish itself (not even English I can put in).

What can I do that I haven’t done to solve the problem?
If it was possible to select English I could still play, but in Spanish I can’t.

Thanks for all.

2 Likes

I have the exact same issue; the game is in Spanish and the only languages I can select are Spanish and Korean. Reinstalling Diablo IV, Battle.net, logging in and out, clearing all the settings I can find, setting the TextLocale and SoundLocal value in Documents/Diablo IV/LocalPrefs.txt to “2”, updating Windows, they all do nothing.

Interestingly, clicking “Reset to defaults” / “Restablecer valores” (middle red button at the bottom) in the Accessibility settings in-game causes all the strings in the game to become blank/missing.

Guess I’m learning Spanish now. :joy:

Jokes aside, paying 90 USD for the Deluxe Edition and having this sort of experience feels kinda bad (particularly when the only reason I bought the Deluxe Edition was for early access that I now can’t make use of).

The FenrisDebug text file in the Diablo IV main installation folder gives some insight.
The client somehow seems to have issues in finding the correct locales:

I 2023.06.03 11:46:42.642900 [Game] Adjusted initial working directory: D:\Spiele\Diablo IV
I 2023.06.03 11:46:42.642909 [Game] Detecting installed Base locales:
I 2023.06.03 11:46:42.642912 [Game] Found: enUS
I 2023.06.03 11:46:42.642928 [Game] Found: deDE
I 2023.06.03 11:46:42.642932 [Game] Found: koKR
I 2023.06.03 11:46:42.642939 [Game] Found: zhCN
I 2023.06.03 11:46:42.642943 [Game] Found: zhTW
I 2023.06.03 11:46:42.642948 [Game] Found: jaJP
I 2023.06.03 11:46:42.642975 [Game] FileSystemGetLocale, AgentSettings: 1
I 2023.06.03 11:46:42.642977 [Game] FileSystemGetLocale, using agent locale: enUS
I 2023.06.03 11:46:42.642978 [Game] FileSystemGetLocale, returned locale: enUS
I 2023.06.03 11:46:42.642980 [Game] Detecting installed Speech locales:
I 2023.06.03 11:46:42.642986 [Game] Found: deDE
I 2023.06.03 11:46:42.643007 [Game] FileSystemGetLocale, AgentSettings: 1
I 2023.06.03 11:46:42.643009 [Game] FileSystemGetLocale, using agent locale: deDE
I 2023.06.03 11:46:42.643011 [Game] FileSystemGetLocale, returned locale: deDE
I 2023.06.03 11:46:42.643012 [Game] Detecting installed Text locales:
I 2023.06.03 11:46:42.643017 [Game] Found: esES
I 2023.06.03 11:46:42.643024 [Game] Found: koKR
I 2023.06.03 11:46:42.643042 [Game] FileSystemGetLocale, AgentSettings: 1
I 2023.06.03 11:46:42.643045 [Game] FileSystemGetLocale, Agent wants us deDE, but it is not installed. Falling back to registry and then the first installed locale.
I 2023.06.03 11:46:42.643071 [Game] FileSystemGetLocale, using registry locale: esES
I 2023.06.03 11:46:42.643073 [Game] FileSystemGetLocale, returned locale: esES
I 2023.06.03 11:46:42.643796 [Game] SNOFilesInitialize(‘Data’, PC, enUS, deDE (Speech), esES (Text)
I 2023.06.03 11:46:42.748156 [Game] SNOFileLoadTextFile: ‘Data\Locale\esES\declension.txt’
I 2023.06.03 11:46:42.748165 [Game] No TACT path found for ‘Data\Locale\esES\declension.txt’

Bumping this thread up, as this is a game breaking bug!

Bumping this as well. Happening to me on one of my computers…

Having the same problem on my laptop. Oddly got it to work on a steam deck just fine but normal laptop isn’t going so well

Found a fix, my install location was originally on the :C drive, after reinstalling it into the Programs x86, the issue has resolved. Not sure why, but it has worked for me. I have not tested simply moving files into this folder, but i imagine it would work.

Hey guys, I also reinstalled windows 10 and it worked. I also activated Windows where before it was not activated. Been good since and that was over 24 hours ago. It took half a day to happen last time. Fingers crossed!

Your programs x86 folder should be located on your C drive.

Same problem on 3 of my 4 computers/accounts, after last patch 1.0.3.42936 the 3 computers keep setting TextLocale to trTR. Reinstall of game and battle net does nothing, compy game from working computer nothing. change reg string it just changes it back after you hit play.

I 2023.07.02 03:34:26.539529 [Game] FileSystemGetLocale, AgentSettings: 1
I 2023.07.02 03:34:26.539534 [Game] FileSystemGetLocale, Agent wants us enUS, but it is not installed. Falling back to registry and then the first installed locale.
I 2023.07.02 03:34:26.539569 [Game] FileSystemGetLocale, registry locale(enUS) is not valid.
I 2023.07.02 03:34:26.539582 [Game] Detecting first installed locale.
I 2023.07.02 03:34:26.539615 [Game] Detected: trTR (Text)
E 2023.07.02 03:34:26.539621 [Game] Falling back to first installed locale.
I 2023.07.02 03:34:26.539627 [Game] FileSystemGetLocale, returned locale: trTR
I 2023.07.02 03:34:26.541734 [Game] SNOFilesInitialize(‘Data’, PC, enUS, enUS (Speech), trTR (Text)
I 2023.07.02 03:34:27.017030 [Game] SNOFileLoadTextFile: ‘Data\Locale\trTR\declension.txt’
I 2023.07.02 03:34:27.017049 [Game] No TACT path found for ‘Data\Locale\trTR\declension.txt’