SOLUTION to at least get in

All credit given to original author in Bug Forum.


4 posts


I finally found a way to get into the freakin game. Found the solution in a reddit thread. Go into your diablo folder and move the “dstorage.dll” file to your desktop and then just run the game. Maybe you can just delete the file but just to be safe keep the file.

His (her) solution at last got me into the game… haven’t run around enough yet to see how well the game is functioning.

Just re-posting for people to see since it’s a little buried.


Thank you very much, it worked <3

Yeah, this shouldn’t work, but it did for me. Lordy

This actually works!!!

Its insane how people on forums exceed Blizzard’s staff ability to fix this, its been how many hours since patch with this issue 30-40?. some more layoffs probably coming in.

Thank you so much!!! <3

You may need to do this again and again, just FYI.

I see this ugly bug has reared its head again. Usually the file will get re-created, just keep that in mind.

1 Like

I never got this crash bug until post 1.3.1 patch. i did a fresh install /updated nvidia drivers etc. i couldn’t get in until I renamed dstorage.dll

I understand. Still, this (dstorage issue) has been a problem off and on since launch. I personally have not had an issue with it however and still don’t.

renamed dstorage.dll to what? My game locks up when it tries to log into the server, or if I don’t click through the opening screens it locks up about 10secs into the launch

Removing the dstorage.dll fixed my crash at login issue as well.

dstorage.dll.bak this is what you rename the file to

Technically you can rename it to anything, or even just delete it. If you look, you can find this file in a lot of folders all over the drive.

Its part of Direct Storage for Microsoft as a gaming API to better handle performance for NVME SSD drives by allowing the GPU to directly access the drive for the game files.

What’s funny about this, is that my SSD IS a Kingston Fury Renegade drive. Had no idea they had an article on this.

DirectStorage requires game developers to make their games work with it.

Interesting point. That is near the end of the article.

wow, i have done a scan and repair, reinstalled the game, done the benchmark trick. this was the only fix. i havent been able to play for like 3 days now…

this worked, thank you!

I have a suspicion that either the latest patch broke something with dstorage, or dstorage also got an update that broke that.

And it may affect the type of system that you are running or type of SSD the game is on more specifically.

All of you having the issue and this fixes it. What brand and type (NVME or SATA) of SSD do you have the game installed on?

Game is installed on a 4TB WD SN850X NVMe, using MS NVMe driver.

1 Like

this is working for me as of 2/4/24 11:15 Pacific Time.

I don’t understand why at all, but this worked and honestly the game is playing smoother with opening menus and between zones now, than it has been all day. Cheers.

Add another one. Couldn’t get in even after multiple restarts, worked instantly on moving the dll as described.

Thank you! This worked for me.

worked for me

has been causing start up crashes for days. finally an hour ago would not work no matter what I tried.