Game will not connect after download

Downloaded latest patch, and now the game freezes at the Diablo IV screen. Before that it was freezing just before character select screen stating that the game was waiting to load. Please advise…will continue to try in log in.

7 Likes

I have same issue. After Patch now it’s stuck on Blizzard screen and will not continue.

4 Likes

Im having exactly the same issue. Was playing fine. then stopped and downloaded the update. now it crashes at the Red Blizzard entertainment loading screen

4 Likes

same here not working after patch

4 Likes

Exactly the same here. I open the game through the blizzard launcher and the most I can get it to is the logging into diablo 4 part then it just freezes completely. Didn’t have this problem before the patch, please Blizzard fix you game.

4 Likes

Same issue, frozen screen at startup …
Please Blizzard Wake-up !!!

1 Like

After trying over and over again I’ve found that if I sit there and just watch the frozen screen for just over 3 mins the screen unfreezes and it goes to the glowing door. After about 40 seconds or so it will say reconnecting to diablo 4 and then the game will shut down

1 Like

Same here.
copy/paste from another thread:

Also getting freezes and crashes since the patch. Prior to patch it was extremely rare that it would ever crash or freeze on me.

EDIT: Restarted game, restarted PC, did scan and repair. Looked for driver updates and found one that was released on the 24th=GeForce game ready driver update to version 551.23 so I updated the driver.

Still freezing at game entry “Diablo” logo. I managed to get in once but crashed as soon as I tried to port to a town.

2 Likes

Don’t know why but seems to work now :face_with_raised_eyebrow:

Still no worky for me :cry:

1 Like

yes me too it’s not stable, crash during the game and no way to connect now :cry:

Same issue. Have cleared the video cache. :confused:

My client is freezing after connecting to Diablo 4 Services, but before advancing to the character select screen. Windows 11. It freezes to the point where the native windows popup asking if I want to close program pops up.

1 Like

Similar. The game seemed to start to load, did the <1 min queue thing, then froze when that time was up. I’ve tried r-click > close window several times, but nothing happens. I’ve even closed bnet, and it still shows the game as frozen.

1 Like

I’ve tried multiple things on my end, this is acting like a backend or aws issue.

I don’t know if it will help anyone, but I was getting stuck on the red Blizzard screen at least a dozen times. I noticed it froze right after the GeForce Experience overlay notification popped up. I just disabled GeForce Experience notifications and it worked without incident. Hope this helps someone.

Just checked and it seems I turned off my overlay a while ago so its not that. I just wish Blizzard would actually reply to one of these countless posts telling us that they are trying to fix the issue. I haven’t seen a blue post from them for so long its almost like they just don’t care.

I finally found a way to get into the freakin game. Found the solution in a reddit thread. Go into your diablo folder and move the “dstorage.dll” file to your desktop and then just run the game. Maybe you can just delete the file but just to be safe keep the file.

3 Likes

I also have the same issue.
Tried the Scan and Repair function but still to no avail.
32 gb ram and RTX 4070 so it should not be a hardware issue(?)

eyyy! I can vouch this made it work!!! thanks for the temp fix, man! :smiley: