Flooded Depths Boss Fight in Progress

While attempting the dungeon on my Necromancer the end boss fight room has boss fog up preventing me from entering the room saying the fight is in progress. Which is odd since I’m not in a party and I seem to be alone in the dungeon. Tracking the boss on my minimap he seems to be rotating around the room like he is aggroed onto something. Leaving the dungeon from the entrance, or teleporting out and coming back didn’t seem to fix the issue. Restarted the game and cleared the dungeon again and… still the boss fog torments me.


Same issue here. Very annoying

1 Like

Same thing is happening to me as of right now (no party but it is in progress) except he is standing still. I updated the game recently, it may be that?

Happened to me as well, I exited dungeon logged out and tried again and it worked this time. I did avoid getting hit by the trap the 2nd time around maybe that triggers it?

1 Like

you may be unto something, reseted the dungeon twice but got hit by the trap and the fog wall was there for the third made sure to avoid the trap and it worked.

Same here. Restart PC does not help either. No party. Fog wall blocking entrance.

Resetting the dungeon by logging out and then avoiding all traps fixed the problem for me!

this worked for me as well, logged out, logged back in to reset dungeon and avoided the spike traps

1 Like

Still a bug as of now. Got stuck at a loading screen. It’s late anyway…

TLDR: Coincidence or not, avoiding all traps fixed the issue.
This happened to me just now. 11:30PM CST on June 5th.
I reset several times with no luck. Then I tried the ‘avoid the traps’ thing and it seemed to have worked for me.

1 Like

I’ve tried this 3 times now, avoiding the traps on the 2nd and 3rd run but still blocked by the fog while playing solo :frowning:

Yup, still happening. Will try the trap workaround.

I was able to get past this. No idea if it was avoiding the traps or just hte fact that i got a different map layout the second time…

costed me 3 resets. :smiling_face_with_tear:

Still happening, even while avoiding the traps.

i didnt get hit by the trap and it happend to me just now.

Still bugged, and not have been hit with a trap

Still bugged and no luck with the avoiding the traps method. Best to probably just save yourself some sanity and move on until they fix it.

Same here, bugged. Tried restarting multiple times and nothing.

There was a mechanism in the first mini bosses room that I didn’t see that helped me progress. I don’t think we are supposed to see the final boss room so early