Diablo 4 crashes when it is loading

I was having the same issue, I removed the dstorage.dll and the game worked again.

I’m having similar issues. Ever since recent update I cannot play the game at all. It freezes every time I get to loading screen. I have to keep ending it through task manager. I’ve tried to contact blizz about this over and over. Tried so many things to fix this.

Same issue here - completely broken the moment I installed the most recent patch. Honestly I’m about to the point where I want to see if I can get my money back for the game and go back to playing diablo 3, this level of QA is simply unacceptable.

Same here. D4 ran fine on Win 10, just build a new PC with Win 11 and now the game crashes every time on the Blizzard splash screen. I scanned and repaired the files and the issue persists.

Same here, after months of working flawlessly. Running on Windows 11 Pro 23H2, 12th Gen Intel(R) Core™ i7-12700K 3.60 GHz, 16.0 GB (15.7 GB usable), 1T SSD. Installed 1 pending Windows update, updated to latest Nvidia game ready driver 551.23 for GeForce GTX 1660 Ti. I’ve tried Scan and Repair, lower res, set DisableChromaEffects “1” in localprefs.txt and finally uninstall/reinstall. After a few of these steps, got in for a few minutes, seemed to work, porting to town locked it up again then freezing at the Blizzard screen every time. So irritating. Here’s hoping something in the next update fixes what the last one broke.

This has been happening to me since the latest patch. All other games work fine.

I have done a scan and repair of the game files, but will still crash on startup.

running a windows repair in the cmd prompt as administrator seems to resolve this but only temporarily.

run these two lines separately and reboot. see if this helps.

dism /online /cleanup-image /restorehealth

sfc /scannow

Otherwise check this thread - move out dstorage.dll from diablo IV directory

Adding myself to this list. Facing the same issue with being unable to login whatsoever since the latest patch. The d2storage fix, however, seems to have solved the issue.

Thanks for sharing this! Worked for me, although I had to also remove the dstorage and dstoragecore dlls.

The snafu with using the updated DirectStorage files is that the BNet Updater removes them and replaces with the old 1.02 files whenever it scans for an update. What has been working for me, is to rename the 2 original files, and put the newer build files on my system’s PATH so that the game loads them and are safe from BNet updater.

The updater seems happy now to ignore the 2 renamed files.

1 Like

I’m having the same problem. It will either crash on the red Blizzard logo screen or the black screen right after that.
I’m also have frequent disconnects in game while trying to teleport or leave a cellar or dungeon.
This all started after the latest patch.

Same here. Brutally frustrating.
If you clean cache sometimes it opens the gamer, but teleporting mostly disconnects you. also, the game is very laggy now, and the map is screwed up, among other bugs

We believe we have identified the issue. We will have the fix in the next patch. We have identified an immediate workaround as well.

  1. Click the :gear: icon next to your “Play” Button on the Battle.net Launcher
  2. Click on ‘Game Settings’
  3. Click on the ‘Additional command line arguments’ checkbox
  4. Add ‘-disableds’ to the box that appears.
  5. Launch Game
11 Likes

I’m Having the Same Issue Since New Patch 2/1/2024

1 Like

Works for me, thanks

1 Like

I have been having the game hang on the Blizzard splash screen almost 100% of the time. I was briefly able to log in and play, then it crashed to desktop with no error message, and haven’t been able to get back into the game since.

I have AMD 7900 XTX with the most recent drivers installed.

1 Like

Thanks, Adam, you guys are lifesavers! I played this afternoon by renaming both dstorage files, but I will add this fix in as well for the time being. Thanks for the fix!

2 Likes

This has allowed me into the game and able to play for about 3 hours, so it did help me. Thank you. Today is the first time I was even able to get in the game since Thursday night.

1 Like

still doing same won’t load or if does will freeze when tp tree or other areas

1 Like

whenever i port to any place it game will disconnect. Sometimes even redeeming whisper’s gifts will disconnect me

Have tried -disableds and does not work

Since the patch 1.3.1 was installed, the game could practically no longer be started. Even a reinstallation and “scan and repair” did nothing.
With the help of the “command line argument” ‘-disableds’ in the game settings, the game could be started again.
However, it now happens to me again and again that the PC simply switches off when “teleporting”…

My PC otherwise runs “rock stable” and this behaviour also happens when not overclocked (CPU & GPU).
Memory and power supply have also been checked.

The game ran very stable for me until before the patch - now it’s a disaster

1 Like