Diablo 4 crashes when it is loading

I’m having the same issue - since the patch, the game freezes up on one of the two splash screens, or when it goes to the loading screen (before character selection). I’ve run “Scan and Repair” in Battle.net with no success.
Ryzen 7 7800X3D
Samsung 990 Pro
G/Skill Trident Z5 (2x32) DDR5-6000
RTX 2080 Ti
Win 11 Home

This is probably unrelated, but the download/patch process in Battle.net caused my CPU temp to jump might higher than normal. I know the Ryzen 7 runs very hot, but this was out of the ordinary.

1 Like

I am having an issue where either I am in a vault or nightmare dungeon/vault and it just crashed to desktop. Has been happening for about a week now. Hasnt happened any other season nor with any other game. Any ideas?

I would like to know also. Renaming dstorage.dll worked brilliantly.

after patch i can’t play

I was having the same problem of game not loading past splash screen. Had this problem previously when they released early access. Moved game files from my M.2 SSD to my SATA SSD and changed game path in client. This worked for me…hopefully they can fix it soon as game played perfectly well before update.

Here’s the solution, worked for me!

Same thing here, I’ve been trying to log in 2 days Now …
WTF is happening with this Company’s Devs, every patch is worse than the other
I reinstalled Windows on the previous AoZ to fix a GfX Glitch somehow… and now after the patch, the freaking game cant Run, and I Spent money too for this season …

By the way, Last Epoch is running well, Path of Exile is running good,
D4 is a piece of sh…
So it’s not my GFX card Not my WIndows,
Not Any of the other services,
It’s your Code,
Seriously, I hope This DEV team, again I hope, can go home and relax

I know the truth is subjective and sometimes Hurts … Grow up then
(For anyone who things that I’m complaining a bit) :slight_smile:

Hello everyone,

Thanks for those reports and workarounds, this issue has been escalated for investigation.

4 Likes

I saw that there was a hotfix pushed last night, but this morning my game still hangs on loading.

Replacing the DLL files referenced here fixed the issue for me. I am on Win11Pro, 4080 with current drivers, attempted to scan game files, toggled GPU scheduling, and changed HRD settings with no change.

The two files are dstorage.dll and dstoragecore.dll. They are the 2 libraries used to allow the game to use DirectStorage for loading game assets direct to your GPU. The game is using an older build from 1.0, and is causing issues like stuttering and crashing. I managed to get the 2 files from the DirectStorage SDK and replaced them with the current 1.22 build, which solves the game crashing issue, and excessive stutter.

Just note that every time the game updates itself, the 2 1.22 files will get replaced with 1.02 versions again, so you will have to reapply. This is why I am glad to see the Devs noting this, and hopefully they will supply a newer build themselves.

3 Likes

I was having the same issue, I removed the dstorage.dll and the game worked again.

I’m having similar issues. Ever since recent update I cannot play the game at all. It freezes every time I get to loading screen. I have to keep ending it through task manager. I’ve tried to contact blizz about this over and over. Tried so many things to fix this.

Same issue here - completely broken the moment I installed the most recent patch. Honestly I’m about to the point where I want to see if I can get my money back for the game and go back to playing diablo 3, this level of QA is simply unacceptable.

Same here. D4 ran fine on Win 10, just build a new PC with Win 11 and now the game crashes every time on the Blizzard splash screen. I scanned and repaired the files and the issue persists.

Same here, after months of working flawlessly. Running on Windows 11 Pro 23H2, 12th Gen Intel(R) Core™ i7-12700K 3.60 GHz, 16.0 GB (15.7 GB usable), 1T SSD. Installed 1 pending Windows update, updated to latest Nvidia game ready driver 551.23 for GeForce GTX 1660 Ti. I’ve tried Scan and Repair, lower res, set DisableChromaEffects “1” in localprefs.txt and finally uninstall/reinstall. After a few of these steps, got in for a few minutes, seemed to work, porting to town locked it up again then freezing at the Blizzard screen every time. So irritating. Here’s hoping something in the next update fixes what the last one broke.

This has been happening to me since the latest patch. All other games work fine.

I have done a scan and repair of the game files, but will still crash on startup.

running a windows repair in the cmd prompt as administrator seems to resolve this but only temporarily.

run these two lines separately and reboot. see if this helps.

dism /online /cleanup-image /restorehealth

sfc /scannow

Otherwise check this thread - move out dstorage.dll from diablo IV directory

Adding myself to this list. Facing the same issue with being unable to login whatsoever since the latest patch. The d2storage fix, however, seems to have solved the issue.

Thanks for sharing this! Worked for me, although I had to also remove the dstorage and dstoragecore dlls.

The snafu with using the updated DirectStorage files is that the BNet Updater removes them and replaces with the old 1.02 files whenever it scans for an update. What has been working for me, is to rename the 2 original files, and put the newer build files on my system’s PATH so that the game loads them and are safe from BNet updater.

The updater seems happy now to ignore the 2 renamed files.

1 Like