Wont Start - New Apple M1 MacBook Pro

I am trying to run Diablo 3 on the new M1 MacBook Pro - I’ve read reports and seen benchmarks where others were able to run the game. On start before the game opens at all is a popup which states:
“Diablo III was unable to initialize.”

In the Mac.log file:
(Main Thread)[error] Apple Software Renderer isn’t supported

For some reason the game is calling back to a SW renderer, is this fixable?

That’s the error message I was getting, but latest beta fixed it. But some were able able run it before the latest beta. If you migrated your apps. I would delete all D3 related files and reinstall. Reinstall fixed issues with some of my other apps.



Can you please try launching the game with Rosetta following the steps here Let us know if that helped or if reinstalling was the fix.

Thank you!

1 Like

with my m1 Mac mini i complete deinstall DiabloIII and Battle net new Install and there result is _ Applikation unable to intitialize …

updated to the latest OS?

How should this be possible?
As far as I know Diablo 3 is no universal binary, and you only have the choice between native and Rosetta for universal binaries.

With Intel binaries you do not have a choice and they always run through Rosetta.

Anyways, tried it today on my new M1 Mac and honestly it is running great, usually between 50 and 60 fps even on native resolution which is more then I expected from an IGP